
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<!-- Invisibly Pixel Code added July 2019-->



<script>
window.ia = window.ia || function ()
{ (window.ia.q = window.ia.q || []).push(arguments); }
;
ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script async src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script >
docReady(function()
{ims.startServices();}
);
</script>


<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<link rel="alternate" type="application/rss+xml" title="Under the Radar" href="http://www.undertheradarmag.com/site/rss" />
<link rel="icon" type="image/x-icon" href="/i/favicon.gif" />
<link rel="stylesheet" href="http://www.undertheradarmag.com/?css=common/print.v.1615215086" media="print" />
<title>Francisco Martin Debuts New EP &#039;Beautiful Ramblings of A Restless Mind&#039; - Stream It Below | Under The Radar Magazine</title>
<meta name='keywords' content='Francisco Martin, Beautiful Ramblings of A Restless Mind, EP, pop, singer/songwriter' />
<meta name='description' content='After making his debut in late 2020 with his single “Swollen,” San Francisco-based multi-instrumentalist, producer, and singer/songwriter Francisco Martin has returned, sharing his debut EP Beautiful Ramblings of A Restless Mind. Inspired by emotive pop singer/songwriters like James Bay and Maggie Rogers, the new EP reveals a thoughtful emotive side to Martin, marrying together rich pop melody and resonant songwriting.  ' />
<link rel='canonical' href='http://www.undertheradarmag.com/news/francisco_martin_debuts_new_ep_beautiful_ramblings_of_a_restless_mind_strea' />
<!-- generated by seo_lite -->
<meta property="og:title" content="Francisco Martin Debuts New EP &#8216;Beautiful Ramblings of A Restless Mind&#8217; - Stream It Below" />
<meta property="og:url" content="http://www.undertheradarmag.com/news/francisco_martin_debuts_new_ep_beautiful_ramblings_of_a_restless_mind_strea" />
<meta property="og:image" content="http://www.undertheradarmag.com/uploads/article_images/41EFD273-057D-456A-BCA7-3BF6BBABA635.jpeg" />

<script type='text/javascript' src='http://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js'></script>
<script type='text/javascript' src='/assets/js/site.js'></script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/5381216/UTR_FullSite_Above_Header', [970, 250], 'div-gpt-ad-1549375964849-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Leaderboard_728x90', [728, 90], 'div-gpt-ad-1549376291664-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Square_300x250', [300, 250], 'div-gpt-ad-1549376717402-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Skyscraper_160x600', [160, 600], 'div-gpt-ad-1549376881449-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Skyscraper_Right_bottom', [160, 600], 'div-gpt-ad-1549376944969-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Leaderboard-Bottom', [728, 90], 'div-gpt-ad-1549376996058-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Skyscraper_left_side', [160, 600], 'div-gpt-ad-1549377117457-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'http://cdn.taboola.com/libtrc/undertheradar/loader.js');
</script>
<link href="https://fonts.googleapis.com/icon?family=Material+Icons" rel="stylesheet">

<link type="text/css" rel="stylesheet" href="/assets/css/materialize.css?v1"  media="screen,projection"/>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>

<!-- adding March 17 2020 for BandsintownPlay-->
<link rel="stylesheet" href="https://static.solutionshindsight.net/topics/smartTagging.css"/>
<script async src="https://static.solutionshindsight.net/topics/smartTagging.js"></script>

<head>
<title>Under the Radar | Music Blog for the Indie Music Magazine</title>
</head>
<body class="news">
<div id="7aafabf1-e503-44b7-a787-b8a926396bd9" class="_inv_marker"></div>

<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-7749100-1");
pageTracker._trackPageview();
} catch(err) {}</script>

<div id="page" class="container">

<!-- /5381216/UTR_FullSite_Above_Header -->
<div class="ad">
<div id="div-gpt-ad-1549375964849-0" style="height:250px; width:970px;margin-left:-10px;" class="hide-on-med-and-down">
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549375964849-0');});</script>
</div>
</div>


<div id="header" class="row">

  <nav>
    <div class="nav-wrapper">
      <a href="/" class="brand-logo left"><img src="/i/logo.jpg" alt="Under The Radar" /></a>
      <a href="#" data-target="mobile-demo" class="sidenav-trigger"><i class="material-icons">menu</i></a>

<div id="topad" class="hide-on-med-and-down">
<!-- /5381216/UTR_FullSite_Leaderboard_728x90 -->
<div id='div-gpt-ad-1549376291664-0' style='height:90px; width:728px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376291664-0');});</script>
</div>
</div>
      <ul id="nav-mobile" class="right hide-on-med-and-down">
                <li id="news"><a href="http://www.undertheradarmag.com/news">News</a></li>
		<li id="interviews"><a href="http://www.undertheradarmag.com/interviews">Interviews</a></li>
		<li id="reviews"><a href="http://www.undertheradarmag.com/reviews">Reviews</a></li>
		<li id="blog"><a href="http://www.undertheradarmag.com/blog">Blog</a></li>
		<li id="galleries"><a href="http://www.undertheradarmag.com/galleries">Galleries</a></li>
		<li id="issues"><a href="http://www.undertheradarmag.com/issues/current">Current Issue</a></li>
		<li id="artists"><a href="http://www.undertheradarmag.com/artists">Artists</a></li>
		<li id="ptmy"><a href="http://www.undertheradarmag.com/ptmy">Pleased to Meet You</a></li>
		<li id="media" class="last"><a href="/media/">Media</a></li>
	</ul>
    </div>
  </nav>	

  <ul class="sidenav" id="mobile-demo">
                <li><a href="http://www.undertheradarmag.com/news">News</a></li>
		<li><a href="http://www.undertheradarmag.com/interviews">Interviews</a></li>
		<li><a href="http://www.undertheradarmag.com/reviews">Reviews</a></li>
		<li><a href="http://www.undertheradarmag.com/blog">Blog</a></li>
		<li><a href="http://www.undertheradarmag.com/galleries">Galleries</a></li>
		<li><a href="http://www.undertheradarmag.com/issues/current">Current Issue</a></li>
		<li><a href="http://www.undertheradarmag.com/artists">Artists</a></li>
		<li><a href="http://www.undertheradarmag.com/ptmy">Pleased to Meet You</a></li>
		<li><a href="/media/">Media</a></li>
	        <li><a href="http://www.undertheradarmag.com/subscribe">Subscribe</a></li>
	        <li><a href="http://www.undertheradarmag.com/advertise">Advertise</a></li>
  </ul>
</div><!--/header-->

<div id="utility" class="row clearfix">

      <div class="today-date col hide-on-small-only m3 l3">
	Wednesday, May 12th, 2021
      </div>

       <div class="social col s5 m4 l4">
        <span id="facebook"><a href="http://facebook.com/UnderTheRadarMagazine"></a></span>        
        <span id="twitter"><a href="http://twitter.com/Under_Radar_Mag"></a></span>
        <span id="tumblr"><a href="http://under-radar-mag.tumblr.com/"></a></span>
        <span id="instagram"><a href="http://instagram.com/undertheradarmag"></a></span>
        <span id="pinterest"><a href="http://pinterest.com/underradarmag/"></a></span>
        <span id="rss"><a href="http://www.undertheradarmag.com/site/rss"></a></span>
         </div>

         <div class="search col s7 m5 l5">
	<span id="subscribe" class="hide-on-med-and-down"><a href="http://www.undertheradarmag.com/subscribe">Subscribe</a></span>
	<span id="advertise" class="hide-on-med-and-down"><a href="http://www.undertheradarmag.com/advertise">Advertise</a></span>
      	<span>
		<form id="search" method="post" action="http://www.undertheradarmag.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="19" />
<input type="hidden" name="RES" value="" />
<input type="hidden" name="meta" value="ESA+v24aZv4k6o4bZjFEyGhoKbMQpyq6ey8fIZdKiLQeumTGKAmSMerREuDjnCIrLHyVUV6SC4kOencjbedTALeLh/hcowE2MbggjwW6SQQQyLsEefWL+7GFpReC1/2X5EQOB9Re8zVmBzOXrqRysQlZ9Vw18cFktTfVt45Hg0UjJtaJyYhjw28Yzzr0P8rhMJcjXl/RPiOxZC8wlq8gxC2wtqm/Rl4hKjREYKliIeiw/V322HGzX79G5hg6NqhnWa2l+8KWNm3I93JG3Akuu7sXJa0xJGs0WMNn7tOm/qdkVWINMMjpk0OybDI68Sr46EM6L3VG33FsS+agzJP9UBFGydcaw0pnz2VMUfEj9pUC3A6X5WgPZTSRKKruE9qc5zBitMXLZjAtuh/Wge5JYyBT6bmH0Wrqj/ZPCjOS5Rc=" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="4c4d6411ce725c8d92125be53f9716179cc37ab2" />
</div>


		<fieldset>
		<input type="text" class="input" maxlength="100" size="40" name="keywords" id="keywords" />
                <input id="submit" type="submit" value="Search" class="submit" />
		</fieldset>
		</form>
	</span>
         </div>
</div>	

<div id="content"  class="container">

<div class="row">



<!-- Main -->


<div id="main" class=" col s12 m9 l9">

	<ul id="pagenav" class="clearfix">
		<li><h2>News</h2></li>
		<li id="all"><a href="/news/">All</a></li>
	</ul>


	<div class="dominant">
	
	<img src="http://www.undertheradarmag.com/uploads/article_images/41EFD273-057D-456A-BCA7-3BF6BBABA635.jpeg" width="696" alt="" /><br />
	
	
	</div>
	
	<div id="headline">
		<h3>Francisco Martin Debuts New EP &#8216;Beautiful Ramblings of A Restless Mind&#8217; - Stream It Below</h3>
		<h4>Out Now Via 19 Recordings</h4>
	</div>
	
		<p class="details">
		<span class="date">May 11, 2021</span>

		<span class="byline">By Caleb Campbell</span>

		
		<br />
	<script type="text/javascript">var addthis_pub="4a0dbe61011c49a9";</script>
<a href="http://www.addthis.com/bookmark.php?v=20" onmouseover="return addthis_open(this, '', 'http://www.undertheradarmag.com/news/francisco_martin_debuts_new_ep_beautiful_ramblings_of_a_restless_mind_strea', 'Francisco Martin Debuts New EP &#8216;Beautiful Ramblings of A Restless Mind&#8217; - Stream It Below')" onmouseout="addthis_close()" onclick="return addthis_sendto()"><img src="http://s7.addthis.com/static/btn/lg-share-en.gif" class="addthisimg" width="125" height="16" alt="Bookmark and Share" style="margin-top: 10px;border:0"/></a><script type="text/javascript" src="http://s7.addthis.com/js/200/addthis_widget.js"></script>

<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style" style="float: left;">
	<a class="addthis_button_tweet"></a>
	<a class="addthis_button_facebook_like" fb:like:layout="button_count"></a>
</div>
<br />
<script type="text/javascript">var addthis_config = {"data_track_clickback":true};</script>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4ddd5ddb168a3def"></script>
<!-- AddThis Button END -->
	</p>
		 
		
	<p>​After making his debut in late 2020 with his single “Swollen,” San Francisco-based multi-instrumentalist, producer, and singer/songwriter <a href="http://www.undertheradarmag.com/artists/francisco_martin1" title="Francisco Martin">Francisco Martin</a> has returned, sharing his debut EP <i>Beautiful Ramblings of A Restless Mind</i>. Inspired by emotive pop singer/songwriters like James Bay and Maggie Rogers, the new EP reveals a thoughtful emotive side to Martin, marrying together rich pop melody and resonant songwriting. </p>

<p>  Most of all, the EP is a reflection on love in its various forms. Martin longs for intimacy on “Lover” and pines for lost romance on “Let You Go” and “Swollen,” despairs mistakes he’s made on “I Try” and celebrates young love and lust on “Wild Girl.” It’s a singular focus, but one that allows Martin to examine love from different angles, playing into heartbroken angst as effortlessly as he does sweet celebrations. </p>

<p>  Uniting it all is Martin’s steadfast pop sensibilities. Taking on influences both classic and modern, Martin places himself among the ranks of breezy pop songwriters, always reaching for sun-lit hooks and sweet melodies. Even in the EP’s moments of longing heartbreak Martin’s delivery has the feel of a wide-eyed romantic, carried by the hopeful high points of the record. </p>

<p>  As Martin explains, “This EP is about love, loneliness and heartache. It’s an emotional journey; a conversation. It’s a little bit about falling in love, a little bit about yearning for love; and a little bit about losing one of the first loves of my life.” Check out the EP below, out now via 19 Recordings. </p>

<iframe src="https://open.spotify.com/embed/album/7dLRlhbhVCbq3evSYLPYzt" width="300" height="380" frameborder="0" allowtransparency="true" allow="encrypted-media"></iframe> <iframe allow="autoplay *; encrypted-media *; fullscreen *" frameborder="0" height="450" style="width:100%;max-width:660px;overflow:hidden;background:transparent;" sandbox="allow-forms allow-popups allow-same-origin allow-scripts allow-storage-access-by-user-activation allow-top-navigation-by-user-activation" src="https://embed.music.apple.com/us/album/beautiful-ramblings-of-a-restless-mind-ep/1560273942"><p></iframe></p>

<br /><br />
<script>
/* In-Read undertheradarmag */
(function() {
	var opts = {
		artist: "",
		song: "",
                detect_artist: true,
		adunit_id: 100001447,
		div_id: "cf_async_" + Math.floor((Math.random() * 999999999))
	};
	document.write('<div id="'+opts.div_id+'"></div>');var c=function(){cf.showAsyncAd(opts)};if(typeof window.cf !== 'undefined')c();else{cf_async=!0;var r=document.createElement("script"),s=document.getElementsByTagName("script")[0];r.async=!0;r.src="//srv.clickfuse.com/showads/showad.js";r.readyState?r.onreadystatechange=function(){if("loaded"==r.readyState||"complete"==r.readyState)r.onreadystatechange=null,c()}:r.onload=c;s.parentNode.insertBefore(r,s)};
})();
</script>

<div id="ac5b40b8-b46a-4683-8e5f-ae810fc8e1b6" class="_inv_marker"></div>

<div class="ad interior">
<!-- /5381216/UTR_FullSite_Square_300x250 -->
<div id='div-gpt-ad-1549376717402-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376717402-0');});
</script>
</div>
</div>



<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

<div id="comments">
	<h3>Comments</h3>
	<div id="comments-form" class="clearfix">
		<h4>Submit your comment</h4>
<form id="comment_form" method="post" action="http://www.undertheradarmag.com/news/francisco_martin_debuts_new_ep_beautiful_ramblings_of_a_restless_mind_strea"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="1" />
<input type="hidden" name="RET" value="http://www.undertheradarmag.com/news/francisco_martin_debuts_new_ep_beautiful_ramblings_of_a_restless_mind_strea" />
<input type="hidden" name="URI" value="news/francisco_martin_debuts_new_ep_beautiful_ramblings_of_a_restless_mind_strea" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="entry_id" value="47041" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="4c4d6411ce725c8d92125be53f9716179cc37ab2" />
</div>

<p><input name="name" type="text" class="text" value="" />Name <span class="vamp">Required</span></p>
		<p><input name="email" type="text" class="text" value="" />Email <span class="vamp">Required, will not be published</span></p>		
		<p><input name="url" type="text" class="text" value="http://" />URL</p>
		<p><textarea name="comment"></textarea></p>
		<p>
			<input type="checkbox" name="save_info" value="yes"  /> Remember my personal information<br />
			<input type="checkbox" name="notify_me" value="yes"  /> Notify me of follow-up comments?
		</p>

		<p>Please enter the word you see in the image below:</p>
		<p id="captcha">
			<img src="/images/captchas/1620810952.1313.jpg" width="140" height="30" style="border:0;" alt=" " /><input type="text" class="text" name="captcha" value="" maxlength="20" />
		</p>

		<p><input id="submit-comment" type="submit" value="Submit" /></p></form>
	</div>

	<p id="nocomments">There are no comments for this entry yet.</p>
	
</div>

</div>


<!-- Right Rail -->
<div id="rightrail" class="rail  col s12 m3 l3">

		<div class="module">
			<h2><a href="/issues/current/"><b>Current Issue</b></a></h2>
			<a href="http://www.undertheradarmag.com/issues/46771"><img src="http://www.undertheradarmag.com/uploads/cover_images/Under_the_Radar_Issue_68_Cover_Japanese_Breakfast_HAIM_696_Protest_Issue_Issue_Page.jpg" width="204" alt="" /></a>
			<h3><a href="http://www.undertheradarmag.com/issues/46771"><strong>Issue #68</strong></a></h3>
			<p class="details">
				<span class="date">Apr 21, 2021</span>
				<a href="http://www.undertheradarmag.com/issues/46771">Issue #68 - Japanese Breakfast and HAIM (The Protest Issue)</a>
			</p>
                  </div>
	



 
	<div class="module">
		<h2><b>Most Recent</b></h2>
	<ul class="zebra">
				
			
						
                    	
                    	
                    	
						<li class="stripe"><a href="/news/sleater_kinney_announce_new_album_share_video_for_new_song_worry_with_you"><strong>Sleater-Kinney Announce New Album, Share Video for New Song “Worry With You”</strong> (News) &mdash; Sleater-Kinney, Carrie Brownstein, Wilco</a></li>			
						<li  ><a href="/reviews/the_killing_of_two_lovers"><strong>The Killing of Two Lovers</strong> (Review) &mdash; </a></li>			
                    	
						<li class="stripe"><a href="/news/king_gizzard_the_lizard_wizard_announce_second_new_album_of_2021"><strong>King Gizzard &amp; The Lizard Wizard Announce Second New Album of 2021</strong> (News) &mdash; King Gizzard &amp; The Lizard Wizard</a></li>			
                    	
						<li  ><a href="/news/uv_tv_share_new_song_always_something"><strong>UV-TV Share New Song “Always Something”</strong> (News) &mdash; UV-TV</a></li>			
                    	
						<li class="stripe"><a href="/news/premiere_blvck_hippie_debut_new_video_for_bunkbed"><strong>Premiere: Blvck Hippie Debut New Video For “Bunkbed”</strong> (News) &mdash; Blvck Hippie</a></li>
			
				</ul>
	</div>


	
<div class="ad">

<!-- /5381216/UTR_FullSite_Skyscraper_160x600 -->
<div id='div-gpt-ad-1549376881449-0' style='height:600px; width:160px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376881449-0');});</script>
</div>
<br />
</div>

	<div class="ad"><a href="http://twitter.com/under_radar_mag" target="_blank" onclick="pageTracker._trackPageview('/outgoing/Twitter');"><img src="http://www.undertheradarmag.com/uploads/ads/d4eb7c808a2baa538f2f5d6ee374fe33.jpg" alt="" /></a></div>
         <br />


	
<div class="ad">
<!-- /5381216/UTR_ROS_Skyscraper_Right_bottom -->
<div id='div-gpt-ad-1549376944969-0' style='height:600px; width:160px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376944969-0');});</script>
</div>
</div>

</div><!--/right-rail-->

</div> <!--end content/row-->	




<div id="footer-ad" class="hide-on-med-and-down">
<!-- /5381216/UTR_ROS_Leaderboard-Bottom -->
<div id='div-gpt-ad-1549376996058-0' style='height:90px; width:728px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376996058-0');});</script>
</div>
</div>

<div id="footer">
	<a href="http://www.undertheradarmag.com/contact">Contact</a>
	<a href="http://www.undertheradarmag.com/site/static/staff">Staff</a>
	<a href="http://www.undertheradarmag.com/about">About Us</a>
	<span id="credit">Site by <a href="http://someoddpilot.com/">Someoddpilot</a> &amp; <a href="http://methodtree.com">Methodtree, Inc.</a></span>
	<a href="/" class="copyright">&copy; Under The Radar Magazine</a>
</div>

</div> <!--end page-->

<script type="text/javascript" src="/assets/js/materialize.min.js"></script>


<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

</body>
</html>