
	<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<!-- Invisibly Pixel Code added July 2019-->

<script>
window.ia = window.ia || function ()
{ (window.ia.q = window.ia.q || []).push(arguments); }
;
ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script async src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script >
docReady(function()
{ims.startServices();}
);
</script>


<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<link rel="alternate" type="application/rss+xml" title="Under the Radar" href="https://www.undertheradarmag.com/site/rss" />
<link rel="icon" type="image/x-icon" href="/i/favicon.gif" />
<link rel="stylesheet" href="https://www.undertheradarmag.com/?css=common/print.v.1614229575" media="print" />
<title>X (A24) - review | Under The Radar Magazine</title>
<meta name='keywords' content='X, A24, review, Ti West, movie, film, horror' />
<meta name='description' content='Coming down off the gunpowder rush of his 2016-released Western In a Valley of Violence, Ti West’s newest offering X returns in earnest to the studiously-realized retro horror of 2009’s The House of the Devil, and in doing so, the director has crafted a blood-soaked ’70s Americana fantasia, complemented by explosions of brutal chaos and surreal terror. ' />
<link rel='canonical' href='https://www.undertheradarmag.com/reviews/x_ti_west_a24' />
<!-- generated by seo_lite -->
<meta property="og:title" content="X" />
<meta property="og:url" content="https://www.undertheradarmag.com/reviews/x_ti_west_a24" />
<meta property="og:image" content="https://www.undertheradarmag.com/uploads/review_images/x_ti_west_poster_review_a24.jpg" />

<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js'></script>
<script type='text/javascript' src='/assets/js/site.js'></script>


<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/5381216/UTR_FullSite_Above_Header', [970, 250], 'div-gpt-ad-1549375964849-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Leaderboard_728x90', [728, 90], 'div-gpt-ad-1549376291664-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Square_300x250', [300, 250], 'div-gpt-ad-1549376717402-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Skyscraper_160x600', [160, 600], 'div-gpt-ad-1549376881449-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Skyscraper_Right_bottom', [160, 600], 'div-gpt-ad-1549376944969-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Leaderboard-Bottom', [728, 90], 'div-gpt-ad-1549376996058-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Skyscraper_left_side', [160, 600], 'div-gpt-ad-1549377117457-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>

<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'https://cdn.taboola.com/libtrc/undertheradar/loader.js');
</script>

<link href="https://fonts.googleapis.com/icon?family=Material+Icons" rel="stylesheet">

<link type="text/css" rel="stylesheet" href="/assets/css/materialize.css?v1"  media="screen,projection"/>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>

		<head>
<title>Under the Radar | Music Blog for the Indie Music Magazine</title>
</head>
<body class="reviews review cinema">
<div id="7aafabf1-e503-44b7-a787-b8a926396bd9" class="_inv_marker"></div>

<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-7749100-1");
pageTracker._trackPageview();
} catch(err) {}</script>

<div id="page" class="container">

<!-- /5381216/UTR_FullSite_Above_Header -->
<div class="ad">
<div id="div-gpt-ad-1549375964849-0" style="height:250px; width:970px;margin-left:-10px;" class="hide-on-med-and-down">
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549375964849-0');});</script>
</div>
</div>


<div id="header" class="row">

  <nav>
    <div class="nav-wrapper">
      <a href="/" class="brand-logo left"><img src="/i/logo.jpg" alt="Under The Radar" /></a>
      <a href="#" data-target="mobile-demo" class="sidenav-trigger"><i class="material-icons">menu</i></a>

<div id="topad" class="hide-on-med-and-down">
<!-- /5381216/UTR_FullSite_Leaderboard_728x90 -->
<div id='div-gpt-ad-1549376291664-0' style='height:90px; width:728px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376291664-0');});</script>
</div>
</div>
      <ul id="nav-mobile" class="right hide-on-med-and-down">
                <li id="news"><a href="https://www.undertheradarmag.com/news">News</a></li>
		<li id="interviews"><a href="https://www.undertheradarmag.com/interviews">Interviews</a></li>
		<li id="reviews"><a href="https://www.undertheradarmag.com/reviews">Reviews</a></li>
		<li id="blog"><a href="https://www.undertheradarmag.com/blog">Blog</a></li>
		<li id="galleries"><a href="https://www.undertheradarmag.com/galleries">Galleries</a></li>
		<li id="issues"><a href="https://www.undertheradarmag.com/issues/current">Current Issue</a></li>
		<li id="artists"><a href="https://www.undertheradarmag.com/artists">Artists</a></li>
		<li id="ptmy"><a href="https://www.undertheradarmag.com/ptmy">Pleased to Meet You</a></li>
		<li id="media" class="last"><a href="/media/">Media</a></li>
	</ul>
    </div>
  </nav>	

  <ul class="sidenav" id="mobile-demo">
                <li><a href="https://www.undertheradarmag.com/news">News</a></li>
		<li><a href="https://www.undertheradarmag.com/interviews">Interviews</a></li>
		<li><a href="https://www.undertheradarmag.com/reviews">Reviews</a></li>
		<li><a href="https://www.undertheradarmag.com/blog">Blog</a></li>
		<li><a href="https://www.undertheradarmag.com/galleries">Galleries</a></li>
		<li><a href="https://www.undertheradarmag.com/issues/current">Current Issue</a></li>
		<li><a href="https://www.undertheradarmag.com/artists">Artists</a></li>
		<li><a href="https://www.undertheradarmag.com/ptmy">Pleased to Meet You</a></li>
		<li><a href="/media/">Media</a></li>
	        <li><a href="https://www.undertheradarmag.com/subscribe">Subscribe</a></li>
	        <li><a href="https://www.undertheradarmag.com/advertise">Advertise</a></li>
  </ul>
</div><!--/header-->

<div id="utility" class="row clearfix">

      <div class="today-date col hide-on-small-only m3 l3">
	Wednesday, April 6th, 2022
      </div>

       <div class="social col s5 m4 l4">
        <span id="facebook"><a href="//facebook.com/UnderTheRadarMagazine"></a></span>        
        <span id="twitter"><a href="//twitter.com/Under_Radar_Mag"></a></span>
        <span id="tumblr"><a href="//under-radar-mag.tumblr.com/"></a></span>
        <span id="instagram"><a href="//instagram.com/undertheradarmag"></a></span>
        <span id="pinterest"><a href="//pinterest.com/underradarmag/"></a></span>
        <span id="rss"><a href="//www.undertheradarmag.com/site/rss"></a></span>
         </div>

         <div class="search col s7 m5 l5">
	<span id="subscribe" class="hide-on-med-and-down"><a href="https://www.undertheradarmag.com/subscribe">Subscribe</a></span>
	<span id="advertise" class="hide-on-med-and-down"><a href="https://www.undertheradarmag.com/advertise">Advertise</a></span>
      	<span>
		<form id="search" method="post" action="https://www.undertheradarmag.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="19" />
<input type="hidden" name="RES" value="" />
<input type="hidden" name="meta" value="ESA+v24aZv4k6o4bZjFEyGhoKbMQpyq6ey8fIZdKiLQeumTGKAmSMerREuDjnCIrLHyVUV6SC4kOencjbedTALeLh/hcowE2MbggjwW6SQQQyLsEefWL+7GFpReC1/2X5EQOB9Re8zVmBzOXrqRysQlZ9Vw18cFktTfVt45Hg0UjJtaJyYhjw28Yzzr0P8rhMJcjXl/RPiOxZC8wlq8gxC2wtqm/Rl4hKjREYKliIeiw/V322HGzX79G5hg6NqhnWa2l+8KWNm3I93JG3Akuu7sXJa0xJGs0WMNn7tOm/qdkVWINMMjpk0OybDI68Sr46EM6L3VG33FsS+agzJP9UBFGydcaw0pnz2VMUfEj9pUC3A6X5WgPZTSRKKruE9qc5zBitMXLZjAtuh/Wge5JYyBT6bmH0Wrqj/ZPCjOS5Rc=" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="4973cf99ec531467d0f15fabfca4221d44ba0526" />
</div>


		<fieldset>
		<input type="text" class="input" maxlength="100" size="40" name="keywords" id="keywords" />
                <input id="submit" type="submit" value="Search" class="submit" />
		</fieldset>
		</form>
	</span>
         </div>
</div>	

<div id="content"  class="container">

<div class="row">



				<!-- Main Rail -->
                <div id="main" class="wrap col s12 m9 l9">

			<ul id="pagenav" class="clearfix">
	<li><h2>Reviews</h2></li>
	<li id="all" class=""><a href="https://www.undertheradarmag.com/reviews">All</a></li>
	<li id="music"><a href="https://www.undertheradarmag.com/reviews/category/music">Music</a></li>
	<li id="dvds"><a href="https://www.undertheradarmag.com/reviews/category/dvds">DVDs</a></li>
	<li id="live"><a href="https://www.undertheradarmag.com/reviews/category/live">Live</a></li>
	<li id="cinema"><a href="https://www.undertheradarmag.com/reviews/category/cinema">Cinema</a></li>
	<li id="tv"><a href="https://www.undertheradarmag.com/reviews/category/tv">TV</a></li>
	<li id="books"><a href="https://www.undertheradarmag.com/reviews/category/books">Books</a></li>
	<li id="comicbooks"><a href="https://www.undertheradarmag.com/reviews/category/comicbooks">Comic Books</a></li>
	<li id="videogames"><a href="https://www.undertheradarmag.com/reviews/category/videogames">Video Games</a></li>
</ul>


			<div class="dominant">
				
					<img src="https://www.undertheradarmag.com/uploads/review_images/x_ti_west_poster_review_a24.jpg" width="396" alt="" /><br />
				
				
			</div>

			<div class="headline">
									<h3><i>X</i></h3>
					<h5>
						Studio: A24<br />
						Written and Directed by Ti West
					</h5>
							</div>




		<p class="details">
		<span class="date">Apr 06, 2022</span>
		<a href="https://www.undertheradarmag.com/issues/webexclusive">Web Exclusive</a>
		<span class="more-details">
			<span class="byline noline">By Austin Saalman</span>
			
		</span>
		<script type="text/javascript">var addthis_pub="4a0dbe61011c49a9";</script>
<a href="http://www.addthis.com/bookmark.php?v=20" onmouseover="return addthis_open(this, '', 'https://www.undertheradarmag.com/reviews/x_ti_west_a24', 'X')" onmouseout="addthis_close()" onclick="return addthis_sendto()"><img src="http://s7.addthis.com/static/btn/lg-share-en.gif" class="addthisimg" width="125" height="16" alt="Bookmark and Share" style="margin-top: 10px;border:0"/></a><script type="text/javascript" src="http://s7.addthis.com/js/200/addthis_widget.js"></script>

<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style" style="float: left;">
	<a class="addthis_button_tweet"></a>
	<a class="addthis_button_facebook_like" fb:like:layout="button_count"></a>
</div>
<br />
<script type="text/javascript">var addthis_config = {"data_track_clickback":true};</script>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4ddd5ddb168a3def"></script>
<!-- AddThis Button END -->
	</p>
		
	
	<p>Coming down off the gunpowder rush of his 2016-released Western <i>In a Valley of Violence</i>, Ti West’s newest offering <i>X </i>returns in earnest to the studiously-realized retro horror of 2009’s <i>The House of the Devil</i>, and in doing so, the director has crafted a blood-soaked ’70s Americana fantasia, complemented by explosions of brutal chaos and surreal terror. As an underrated visionary of the modern American period piece, West renders <i>X</i>, which is set in 1979, nearly indistinguishable from the authentic horror and exploitation releases of that decade, its gritty production value conjuring the shadowy thrills of those now-fabled 20th century grindhouse theaters—the sort of seedy settings in which the armrests are sticky with god knows what and the air smells of stale cigarette smoke.</p>

<p> One instantly begins to experience a sense of deviously nostalgic drive-in enchantment as the film states its intent early on in a captivating shot of a grainy metropolitan skyline, cloaked in the hazy blue glow of a sinister premonition, its silhouette a looming omen of doom. The aesthetic merit of this image is indisputable, West having advanced his filmmaking abilities exponentially with <i>X</i>. As impressive as the film is on a technical level, it<i> </i>also boasts top-notch performances from its talented cast and a solid screenplay, which has clearly been penned with the utmost sincerity, rendering even the film’s most bizarre sequences somehow convincing. West remains a master at integrating the utterly absurd with real-life scenarios, his often endearingly cheeky, indie-centric vision of the genre distinguishing him from his higher-profile, larger-budget peers. More often than not, this approach has worked to his advantage, his creative abilities and vision having culminated in what is arguably his finest work to date. </p>

<p> The film’s plot, which plays something like a Tobe Hooper-directed <i>Boogie Nights</i>, concerns the plight of a rag-tag band of would-be pornographers, who set out into the wilds of rural Texas in hopes of completing a shoot and gaining success in the home video market. The group rents a guesthouse on the isolated farm of elderly couple Howard and Pearl, the latter of whom appears to be experiencing symptoms of dementia, where they plan to make their masterpiece. Mia Goth, whose dual portrayal of Pearl and aspiring pornographic actress Maxine Minx serves as the film’s central performance, leads an excellent cast, which includes Jenna Ortega, Scott “Kid Cudi” Mescudi, Brittany Snow, Martin Henderson, Stephen Ure, Owen Campbell, and James Gaylyn. While each role proves essential to the film as a whole, Goth’s portrayal of Pearl lies at the heart of what is essentially West’s attempt to revamp the art of psychosexual horror, a subgenre which saw its highest cinematic peak during the era in which <i>X</i> is set. She portrays the octogenarian villainess with such humanity that it may be fairer to refer to her as more of a tragic figure than a force of carnage, though she sets plenty of that into motion.</p>

<p> Caught in the crossfire of age, envy, and sexuality, the wispily ghostlike Pearl finds herself ravaged by the futile thirst for youth and beauty, herself denied the pleasures bestowed upon the vigorous young people inhabiting her guesthouse. She wanders the scenery, peeping through windows and drifting down hallways, the film’s tension swelling around her, though she is not necessarily “evil,” at least not so much as <i>The House of the Devil</i>’s sinister Mr. and Mrs. Ulman most certainly are. Both Goth and West succeed in casting Pearl in a relatively sympathetic light, her murderous rampage (or <i>rampages</i>, as this is clearly not Pearl’s first rodeo) rooted in the dusty sorrow and frustration those of us who live to be her age may eventually face. While the film’s level of violence will not disappoint the dedicated gorehound—throats are mutilated, heads are crushed, someone is mauled by a gargantuan alligator—<i>X</i>’s power ultimately resides within its intimate explorations of age and sexuality, innocence and experience, and the human pursuit of beauty. The close attention to detail paid by West and his crew has allowed them to craft a loving homage to retro horror sleaze in a fashion that feels both organic and educated. The film is genuinely thrilling, serving as something of an unofficial companion to <i>The House of the Devil</i>, which is set four years later and applies a similar aesthetic technique. Both are deserving of critical acknowledgement, West remaining a young director to watch. </p>

<p>  </p>

<p> Standing on the shoulders of such obvious influences as <i>The Texas Chainsaw Massacre, Eaten Alive, Psycho</i>, and an array of golden age pornographic and exploitation films, <i>X </i>oozes cult appeal and is destined for comparison to those classic releases. Ti West is in top form here, his vision realized in its entirety thanks to the efforts of its cast—especially Goth and Ortega, who tend to shine in everything they do—and skilled crew. Like so many great horror and exploitation films, <i>X </i>is far more than lurid splatter cinema, its sensational imagery underscored by a contemplative sociocultural message, delivered with unexpectedly stirring eloquence. Perhaps horror will at last see its long-awaited renaissance, with filmmakers such as West boldly repaving that long, forgotten road. (<a href="http://www.a24films.com/" target="_blank">www.a24films.com</a>)</p>

	
	<p id="rating">
	Author rating: <b>7.5</b>/10
	<span id="stars"><span id="blackstars" style="width:157.5px;"></span></span>
	</p>

		<div id="userrating">

	<strong>Rate this movie</strong><br />
	
	

	<form class="hidden" id="ratingform" name="rating" method="post" action="https://www.undertheradarmag.com/reviews/x_ti_west_a24"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="302" />
<input type="hidden" name="RET" value="https://www.undertheradarmag.com/reviews/x_ti_west_a24" />
<input type="hidden" name="URI" value="reviews/x_ti_west_a24" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="entry_id" value="51177" />
<input type="hidden" name="return" value="reviews/x_ti_west_a24/" />
<input type="hidden" name="params_id" value="AebQ33pPXkFRyPD56szYuBB31" />
<input type="hidden" name="ajax_request" value="n" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="4973cf99ec531467d0f15fabfca4221d44ba0526" />
</div>

<span id="noratings">No ratings have been recorded yet.</span>
	<input type="hidden" name="rating" id="rating" value="" />
	

	<div class="stars hidden">
		<a class="star" id="star1" href="#">1</a>
		<a class="star" id="star2" href="#">2</a>
		<a class="star" id="star3" href="#">3</a>
		<a class="star" id="star4" href="#">4</a>
		<a class="star" id="star5" href="#">5</a>
		<a class="star" id="star6" href="#">6</a>
		<a class="star" id="star7" href="#">7</a>
		<a class="star" id="star8" href="#">8</a>
		<a class="star" id="star9" href="#">9</a>
		<a class="star" id="star10" href="#">10</a>
		</div></form>

	</div>
	

<br clear="left" />
<br /><br />

<div class="ad interior">
<!-- /5381216/UTR_FullSite_Square_300x250 -->
<div id='div-gpt-ad-1549376717402-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376717402-0');});
</script>
</div>
</div>



<div id="ac5b40b8-b46a-4683-8e5f-ae810fc8e1b6" class="_inv_marker"></div>

<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>


<div id="comments">
	<h3>Comments</h3>
	<div id="comments-form" class="clearfix">
		<h4>Submit your comment</h4>
<form id="comment_form" method="post" action="https://www.undertheradarmag.com/reviews/x_ti_west_a24"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="1" />
<input type="hidden" name="RET" value="https://www.undertheradarmag.com/reviews/x_ti_west_a24" />
<input type="hidden" name="URI" value="reviews/x_ti_west_a24" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="entry_id" value="51177" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="4973cf99ec531467d0f15fabfca4221d44ba0526" />
</div>

<p><input name="name" type="text" class="text" value="" />Name <span class="vamp">Required</span></p>
		<p><input name="email" type="text" class="text" value="" />Email <span class="vamp">Required, will not be published</span></p>		
		<p><input name="url" type="text" class="text" value="http://" />URL</p>
		<p><textarea name="comment"></textarea></p>
		<p>
			<input type="checkbox" name="save_info" value="yes"  /> Remember my personal information<br />
			<input type="checkbox" name="notify_me" value="yes"  /> Notify me of follow-up comments?
		</p>

		<p>Please enter the word you see in the image below:</p>
		<p id="captcha">
			<input type="text" class="text" name="captcha" value="" maxlength="20" />
		</p>

		<p><input id="submit-comment" type="submit" value="Submit" /></p></form>
	</div>

	<p id="nocomments">There are no comments for this entry yet.</p>
	
</div>


</div>


<!-- Right Rail -->
<div id="rightrail" class="rail  col s12 m3 l3">

		<div class="module">
			<h2><a href="/issues/current/"><b>Current Issue</b></a></h2>
			<a href="https://www.undertheradarmag.com/issues/49945"><img src="https://www.undertheradarmag.com/uploads/cover_images/Under_the_Radar_Issue_69_Front_Cover_696.gif" width="204" alt="" /></a>
			<h3><a href="https://www.undertheradarmag.com/issues/49945"><strong>Issue #69</strong></a></h3>
			<p class="details">
				<span class="date">Dec 21, 2021</span>
				<a href="https://www.undertheradarmag.com/issues/49945">Issue #69 - 20th Anniversary Issue</a>
			</p>
                  </div>
	



 
	<div class="module">
		<h2><b>Most Recent</b></h2>
	<ul class="zebra">
				
			
						
                    	
						<li class="stripe"><a href="/news/sunflower_bean_share_video_for_new_song_i_dont_have_control_sometimes"><strong>Sunflower Bean Share Video for New Song “I Don’t Have Control Sometimes”</strong> (News) &mdash; Sunflower Bean</a></li>			
                    	
                    	
						<li  ><a href="/news/hercules_love_affair_and_anohni_team_up_for_new_song_poisonous_storytelling"><strong>Hercules &amp; Love Affair and ANOHNI Team Up for New Song “Poisonous Storytelling”</strong> (News) &mdash; Hercules &amp; Love Affair, ANOHNI</a></li>			
                    	
						<li class="stripe"><a href="/news/niluefer_yanya_shares_new_video_for_the_dealer"><strong>Nilüfer Yanya Shares New Video for “the dealer”</strong> (News) &mdash; Nilüfer Yanya</a></li>			
						<li  ><a href="/reviews/x_ti_west_a24"><strong>X</strong> (Review) &mdash; </a></li>			
                    	
						<li class="stripe"><a href="/news/elf_power_announce_first_new_album_in_five_years_share_undigested_parts"><strong>Elf Power Announce First New Album in Five Years, Share Video for New Song “Undigested Parts”</strong> (News) &mdash; Elf Power</a></li>
			
				</ul>
	</div>


	
<div class="ad">

<!-- /5381216/UTR_FullSite_Skyscraper_160x600 -->
<div id='div-gpt-ad-1549376881449-0' style='height:600px; width:160px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376881449-0');});</script>
</div>
<br />
</div>

	<div class="ad"><a href="//twitter.com/under_radar_mag" target="_blank" onclick="pageTracker._trackPageview('/outgoing/Twitter');"><img src="https://www.undertheradarmag.com/uploads/ads/d4eb7c808a2baa538f2f5d6ee374fe33.jpg" alt="" /></a></div>
         <br />

 
	
<div class="ad">
<!-- /5381216/UTR_ROS_Skyscraper_Right_bottom -->
<div id='div-gpt-ad-1549376944969-0' style='height:600px; width:160px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376944969-0');});</script>
</div>
</div>

</div><!--/right-rail-->

</div> <!--end content/row-->	




<div id="footer-ad" class="hide-on-med-and-down">
<!-- /5381216/UTR_ROS_Leaderboard-Bottom -->
<div id='div-gpt-ad-1549376996058-0' style='height:90px; width:728px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376996058-0');});</script>
</div>
</div>

<div id="footer">
	<a href="https://www.undertheradarmag.com/contact">Contact</a>
	<a href="https://www.undertheradarmag.com/site/static/staff">Staff</a>
	<a href="https://www.undertheradarmag.com/about">About Us</a>
	
	<a href="/" class="copyright">&copy; Under The Radar Magazine</a>
</div>

</div> <!--end page-->

<script type="text/javascript" src="/assets/js/materialize.min.js"></script>


<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>


</body>
</html>