
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en">
<head>
<!-- Invisibly Pixel Code added July 2019-->



<script>
window.ia = window.ia || function ()
{ (window.ia.q = window.ia.q || []).push(arguments); }
;
ia('track', 'PAGE_VIEW');
</script>
<script src="https://pymx5.com/scripts/ready.js"></script>
<script src='https://pymx5.com/scripts/ims.js'></script>
<script async src='https://pymx5.com/scripts/load_tags.js'></script>
<noscript><img height="1" width="1" style="display:none" src="https://api.pymx5.com/v1/sites/track?event_type=PAGE_VIEW&noscript=1"/></noscript>
<script >
docReady(function()
{ims.startServices();}
);
</script>


<meta http-equiv="content-type" content="text/html; charset=utf-8" />
<link rel="alternate" type="application/rss+xml" title="Under the Radar" href="https://www.undertheradarmag.com/site/rss" />
<link rel="icon" type="image/x-icon" href="/i/favicon.gif" />
<link rel="stylesheet" href="https://www.undertheradarmag.com/?css=common/print.v.1615215086" media="print" />
<title>12 Best Songs of the Last Two Weeks: Magdalena Bay, Sea Power, Nation of Language, and More | Under The Radar Magazine</title>
<meta name='keywords' content='Songs of the Week, Magdalena Bay, Sea Power, Nation of Language, Big Thief, Trace Mountains, Macie Stewart, Courtney Barnett, Sufjan Stevens and Angelo De Augustine, Indigo De Souza, Sam Evian, Strand of Oaks, Hayden Thorpe' />
<meta name='description' content='Welcome to the 30th Songs of the Week of 2021. As I was on vacation last week, this week’s list covers the last two week’s worth of songs. So it’s a super-sized edition with a Top 12.' />
<link rel='canonical' href='https://www.undertheradarmag.com/news/12_best_songs_of_the_last_two_weeks_magdalena_bay_sea_power_nation_of_langu' />
<!-- generated by seo_lite -->
<meta property="og:title" content="12 Best Songs of the Last Two Weeks: Magdalena Bay, Sea Power, Nation of Language, and More" />
<meta property="og:url" content="https://www.undertheradarmag.com/news/12_best_songs_of_the_last_two_weeks_magdalena_bay_sea_power_nation_of_langu" />
<meta property="og:image" content="https://www.undertheradarmag.com/uploads/article_images/Songs_of_the_Week_Under_the_Radar_8-13-21.jpg" />

<script type='text/javascript' src='https://ajax.googleapis.com/ajax/libs/jquery/1.3.2/jquery.min.js'></script>
<script type='text/javascript' src='/assets/js/site.js'></script>
<script async='async' src='https://www.googletagservices.com/tag/js/gpt.js'></script>
<script>
  var googletag = googletag || {};
  googletag.cmd = googletag.cmd || [];
</script>

<script>
  googletag.cmd.push(function() {
    googletag.defineSlot('/5381216/UTR_FullSite_Above_Header', [970, 250], 'div-gpt-ad-1549375964849-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Leaderboard_728x90', [728, 90], 'div-gpt-ad-1549376291664-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Square_300x250', [300, 250], 'div-gpt-ad-1549376717402-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_FullSite_Skyscraper_160x600', [160, 600], 'div-gpt-ad-1549376881449-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Skyscraper_Right_bottom', [160, 600], 'div-gpt-ad-1549376944969-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Leaderboard-Bottom', [728, 90], 'div-gpt-ad-1549376996058-0').addService(googletag.pubads());
    googletag.defineSlot('/5381216/UTR_ROS_Skyscraper_left_side', [160, 600], 'div-gpt-ad-1549377117457-0').addService(googletag.pubads());
    googletag.pubads().enableSingleRequest();
    googletag.enableServices();
  });
</script>


<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u) {
    e.async = 1;
    e.src = u;
    f.parentNode.insertBefore(e, f);
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  'https://cdn.taboola.com/libtrc/undertheradar/loader.js');
</script>
<link href="https://fonts.googleapis.com/icon?family=Material+Icons" rel="stylesheet">

<link type="text/css" rel="stylesheet" href="/assets/css/materialize.css?v1"  media="screen,projection"/>
<meta name="viewport" content="width=device-width, initial-scale=1.0"/>

<!-- adding March 17 2020 for BandsintownPlay-->
<link rel="stylesheet" href="https://static.solutionshindsight.net/topics/smartTagging.css"/>
<script async src="https://static.solutionshindsight.net/topics/smartTagging.js"></script>

<head>
<title>Under the Radar | Music Blog for the Indie Music Magazine</title>
</head>
<body class="news">
<div id="7aafabf1-e503-44b7-a787-b8a926396bd9" class="_inv_marker"></div>

<script type="text/javascript">
var gaJsHost = (("https:" == document.location.protocol) ? "https://ssl." : "http://www.");
document.write(unescape("%3Cscript src='" + gaJsHost + "google-analytics.com/ga.js' type='text/javascript'%3E%3C/script%3E"));
</script>
<script type="text/javascript">
try {
var pageTracker = _gat._getTracker("UA-7749100-1");
pageTracker._trackPageview();
} catch(err) {}</script>

<div id="page" class="container">

<!-- /5381216/UTR_FullSite_Above_Header -->
<div class="ad">
<div id="div-gpt-ad-1549375964849-0" style="height:250px; width:970px;margin-left:-10px;" class="hide-on-med-and-down">
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549375964849-0');});</script>
</div>
</div>


<div id="header" class="row">

  <nav>
    <div class="nav-wrapper">
      <a href="/" class="brand-logo left"><img src="/i/logo.jpg" alt="Under The Radar" /></a>
      <a href="#" data-target="mobile-demo" class="sidenav-trigger"><i class="material-icons">menu</i></a>

<div id="topad" class="hide-on-med-and-down">
<!-- /5381216/UTR_FullSite_Leaderboard_728x90 -->
<div id='div-gpt-ad-1549376291664-0' style='height:90px; width:728px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376291664-0');});</script>
</div>
</div>
      <ul id="nav-mobile" class="right hide-on-med-and-down">
                <li id="news"><a href="https://www.undertheradarmag.com/news">News</a></li>
		<li id="interviews"><a href="https://www.undertheradarmag.com/interviews">Interviews</a></li>
		<li id="reviews"><a href="https://www.undertheradarmag.com/reviews">Reviews</a></li>
		<li id="blog"><a href="https://www.undertheradarmag.com/blog">Blog</a></li>
		<li id="galleries"><a href="https://www.undertheradarmag.com/galleries">Galleries</a></li>
		<li id="issues"><a href="https://www.undertheradarmag.com/issues/current">Current Issue</a></li>
		<li id="artists"><a href="https://www.undertheradarmag.com/artists">Artists</a></li>
		<li id="ptmy"><a href="https://www.undertheradarmag.com/ptmy">Pleased to Meet You</a></li>
		<li id="media" class="last"><a href="/media/">Media</a></li>
	</ul>
    </div>
  </nav>	

  <ul class="sidenav" id="mobile-demo">
                <li><a href="https://www.undertheradarmag.com/news">News</a></li>
		<li><a href="https://www.undertheradarmag.com/interviews">Interviews</a></li>
		<li><a href="https://www.undertheradarmag.com/reviews">Reviews</a></li>
		<li><a href="https://www.undertheradarmag.com/blog">Blog</a></li>
		<li><a href="https://www.undertheradarmag.com/galleries">Galleries</a></li>
		<li><a href="https://www.undertheradarmag.com/issues/current">Current Issue</a></li>
		<li><a href="https://www.undertheradarmag.com/artists">Artists</a></li>
		<li><a href="https://www.undertheradarmag.com/ptmy">Pleased to Meet You</a></li>
		<li><a href="/media/">Media</a></li>
	        <li><a href="https://www.undertheradarmag.com/subscribe">Subscribe</a></li>
	        <li><a href="https://www.undertheradarmag.com/advertise">Advertise</a></li>
  </ul>
</div><!--/header-->

<div id="utility" class="row clearfix">

      <div class="today-date col hide-on-small-only m3 l3">
	Saturday, August 14th, 2021
      </div>

       <div class="social col s5 m4 l4">
        <span id="facebook"><a href="//facebook.com/UnderTheRadarMagazine"></a></span>        
        <span id="twitter"><a href="//twitter.com/Under_Radar_Mag"></a></span>
        <span id="tumblr"><a href="//under-radar-mag.tumblr.com/"></a></span>
        <span id="instagram"><a href="//instagram.com/undertheradarmag"></a></span>
        <span id="pinterest"><a href="//pinterest.com/underradarmag/"></a></span>
        <span id="rss"><a href="//www.undertheradarmag.com/site/rss"></a></span>
         </div>

         <div class="search col s7 m5 l5">
	<span id="subscribe" class="hide-on-med-and-down"><a href="https://www.undertheradarmag.com/subscribe">Subscribe</a></span>
	<span id="advertise" class="hide-on-med-and-down"><a href="https://www.undertheradarmag.com/advertise">Advertise</a></span>
      	<span>
		<form id="search" method="post" action="https://www.undertheradarmag.com/"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="19" />
<input type="hidden" name="RES" value="" />
<input type="hidden" name="meta" value="ESA+v24aZv4k6o4bZjFEyGhoKbMQpyq6ey8fIZdKiLQeumTGKAmSMerREuDjnCIrLHyVUV6SC4kOencjbedTALeLh/hcowE2MbggjwW6SQQQyLsEefWL+7GFpReC1/2X5EQOB9Re8zVmBzOXrqRysQlZ9Vw18cFktTfVt45Hg0UjJtaJyYhjw28Yzzr0P8rhMJcjXl/RPiOxZC8wlq8gxC2wtqm/Rl4hKjREYKliIeiw/V322HGzX79G5hg6NqhnWa2l+8KWNm3I93JG3Akuu7sXJa0xJGs0WMNn7tOm/qdkVWINMMjpk0OybDI68Sr46EM6L3VG33FsS+agzJP9UBFGydcaw0pnz2VMUfEj9pUC3A6X5WgPZTSRKKruE9qc5zBitMXLZjAtuh/Wge5JYyBT6bmH0Wrqj/ZPCjOS5Rc=" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="218d0c94bdab9aa668bbe8e58fa462bd3e835174" />
</div>


		<fieldset>
		<input type="text" class="input" maxlength="100" size="40" name="keywords" id="keywords" />
                <input id="submit" type="submit" value="Search" class="submit" />
		</fieldset>
		</form>
	</span>
         </div>
</div>	

<div id="content"  class="container">

<div class="row">



<!-- Main -->


<div id="main" class=" col s12 m9 l9">

	<ul id="pagenav" class="clearfix">
		<li><h2>News</h2></li>
		<li id="all"><a href="/news/">All</a></li>
	</ul>


	<div class="dominant">
	
	<img src="https://www.undertheradarmag.com/uploads/article_images/Songs_of_the_Week_Under_the_Radar_8-13-21.jpg" width="696" alt="" /><br />
	
	
	</div>
	
	<div id="headline">
		<h3>12 Best Songs of the Last Two Weeks: Magdalena Bay, Sea Power, Nation of Language, and More</h3>
		<h4>Plus Big Thief, Trace Mountains, Macie Stewart, and a Wrap-up of the Last Two Weeks’ Other Notable New Tracks</h4>
	</div>
	
		<p class="details">
		<span class="date">Aug 13, 2021</span>

		<span class="byline">By Mark Redfern (with Joey Arnone and Caleb Campbell)</span>

		
		<br />
	<script type="text/javascript">var addthis_pub="4a0dbe61011c49a9";</script>
<a href="http://www.addthis.com/bookmark.php?v=20" onmouseover="return addthis_open(this, '', 'https://www.undertheradarmag.com/news/12_best_songs_of_the_last_two_weeks_magdalena_bay_sea_power_nation_of_langu', '12 Best Songs of the Last Two Weeks: Magdalena Bay, Sea Power, Nation of Language, and More')" onmouseout="addthis_close()" onclick="return addthis_sendto()"><img src="http://s7.addthis.com/static/btn/lg-share-en.gif" class="addthisimg" width="125" height="16" alt="Bookmark and Share" style="margin-top: 10px;border:0"/></a><script type="text/javascript" src="http://s7.addthis.com/js/200/addthis_widget.js"></script>

<!-- AddThis Button BEGIN -->
<div class="addthis_toolbox addthis_default_style" style="float: left;">
	<a class="addthis_button_tweet"></a>
	<a class="addthis_button_facebook_like" fb:like:layout="button_count"></a>
</div>
<br />
<script type="text/javascript">var addthis_config = {"data_track_clickback":true};</script>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#pubid=ra-4ddd5ddb168a3def"></script>
<!-- AddThis Button END -->
	</p>
		 
		
	<p>Welcome to the 30th <a href="http://www.undertheradarmag.com/artists/songs_of_the_week" title="">Songs of the Week</a> of 2021. As I was on vacation last week, this week’s list covers the last two week’s worth of songs. So it’s a super-sized edition with a Top 12.</p>

<p> In the last two weeks we posted interviews with <a href="https://www.undertheradarmag.com/interviews/cults_on_host" title="">Cults</a>, <a href="https://www.undertheradarmag.com/interviews/jessie_ware_on_whats_your_pleasure_the_extended_interview" title="">Jessie Ware</a>, <a href="https://www.undertheradarmag.com/interviews/deep_sea_diver_on_impossible_weight" title="">Deep Sea Diver</a>, <a href="https://www.undertheradarmag.com/interviews/this_is_the_kit_on_off_off_on" title="">This Is the Kit</a>, <a href="https://www.undertheradarmag.com/interviews/future_islands_on_as_long_as_you_are" title="">Future Islands</a>, <i>Swan Song </i>director <a href="https://www.undertheradarmag.com/interviews/swan_song_director_todd_stephens_interview" title="">Todd Stephens</a>, <a href="https://www.undertheradarmag.com/interviews/the_avalanches_on_we_will_always_love_you" title="">The Avalanches</a>, and <i>Beckett </i>director <a href="https://www.undertheradarmag.com/interviews/director_ferdinando_cito_filomarino_on_his_new_netflix_film_beckett" title="">Ferdinando Cito Filomarino</a>.</p>

<p> In the last two weeks we also <a href="http://www.undertheradarmag.com/reviews/category/music/" title="">reviewed a bunch of albums</a>.   </p>

<p> To help you sort through the multitude of fresh songs released in the last two weeks, we have picked the 12 best the last two weeks had to offer, along with highlighting other notable new tracks shared in the last 14 days. Check out the full list below. <b> </b></p>

<p> <b>1. Magdalena Bay: “Secrets (Your Fire)”</b></p>

<p> Los Angeles-based electro-pop duo <a href="https://www.undertheradarmag.com/artists/magdalena_bay" title="">Magdalena Bay</a> (aka Mica Tenenbaum and Matthew Lewin) are releasing their debut full-length album, <i><a href="https://www.undertheradarmag.com/news/magdalena_bay_announce_debut_album_share_video_for_new_song_chaeri" title="">Mercurial World</a></i>, on October 8 via Luminelle. This week they shared its second single, <a href="https://www.undertheradarmag.com/news/magdalena_bay_share_video_for_new_song_secrets_your_fire" title="">“Secrets (Your Fire),”</a> via a fun video that features the band getting sucked into a computer, has them riding dragons, and much more. The song is pure pop bliss. </p>

<p> “Secrets is about interconnectivity, privacy, and digital anxiety,” the band say in a joint press release statement. “It’s also about a need to keep sharing, to keep giving up more and more of yourself to faceless strangers in the hopes of making friends or fans.” </p>

<p> Previously the band shared the album’s first single, <a href="https://www.undertheradarmag.com/news/magdalena_bay_announce_debut_album_share_video_for_new_song_chaeri" title="">“Chaeri,”</a> via a video. “Chaeri” was one of our <a href="https://www.undertheradarmag.com/news/12_best_songs_of_the_week_lump_villagers_magdalena_bay_meatbodies_and_more" title="">Songs of the Week</a>. </p>

<p> <i>Mercurial World </i>is the follow-up to 2020’s <i>A Little Rhythm and a Wicked Feeling</i> EP. The band wrote, produced, and recorded the album themselves.</p>

<p> “We spend all of our time together, and in some ways <i>Mercurial World</i> is about that particular sense of madness in containment,” Lewin said in a previous press release. “We live together and make art together; this immerses you in our creative, insular universe.”</p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/TlhIk7iPU9o" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>2. Sea Power: “Two Fingers”</b> </p>

<p> On Monday <a href="http://www.undertheradarmag.com/artists/british_sea_power/" title="">British Sea Power</a> announced that they have <a href="https://www.undertheradarmag.com/news/british_sea_power_change_name_to_sea_power_announce_new_album_and_share_new" title="">changed their name</a>, shortening it to simply <a href="https://www.undertheradarmag.com/artists/sea_power" title="">Sea Power</a>, and also announced a new album, <i><a href="https://www.undertheradarmag.com/news/british_sea_power_change_name_to_sea_power_announce_new_album_and_share_new" title="">Everything Was Forever</a></i>, and shared its first single, <a href="https://www.undertheradarmag.com/news/british_sea_power_change_name_to_sea_power_announce_new_album_and_share_new" title="">“Two Fingers.”</a> <i>Everything Was Forever </i>is due out February 11, 2022 via the band’s own label Golden Chariot. Check out the album’s tracklist and cover art <a href="https://www.undertheradarmag.com/news/british_sea_power_change_name_to_sea_power_announce_new_album_and_share_new" title="">here</a>. </p>

<p> The name change caused some waves, riling up some patriotic Brits, but regardless of all that “Two Fingers” also happens to be one of the band’s strongest singles in years. </p>

<p> British Sea Power aren’t changing their name due to legal reasons (à la Manitoba to Caribou, Suede to The London Suede, or The Charlatans to The Charlatans UK), nor is it exactly because of potential cultural outrage (à la Dixie Chicks to The Chicks or Lady Antebellum to Lady A, a name change that actually led to outrage when it became clear there was already an established Black blues singer using that moniker). Instead their reasons are a little more nuanced. </p>

<p> The band collectively had this to say about the name change in a <a href="https://seapowerband.com/news/goodbye-british-sea-power-hello-sea-power" target="_blank">statement on their website</a>: “After much reflection and soul-searching, the band formerly known as British Sea Power have modified their name to simply Sea Power. We’ve been British Sea Power for 20 years—an amazing 20 years, when we’ve been able to continually traverse the British Isles, to travel the world, encountering many friendly faces, not least in the band’s remarkable audience. But the name British Sea Power had come to feel constricting, like an ancient legacy we were carrying with us. When we came up with the name British Sea Power there were at least two different lines of thought behind it. There was, literally, sea power—the elementary power of the oceans. Alongside this was the historical idea of ‘British sea power’—Britannia ruling the waves; the naval power that once allowed Britain to dominate the world. When we came up with the original band name, Britain no longer ruled the seas. The band name was intended with a kind of wry humor. The idea of British sea power in the historical sense was an obsolete thing. It was now just the name of a rock band… Now, 20 years later, we’re recasting the name. In recent times there’s been a rise in a certain kind of nationalism in this world—an isolationist, antagonistic nationalism that we don’t want to run any risk of being confused with. It’s become apparent that it’s possible to misapprehend the name British Sea Power, particularly if someone isn’t familiar with the band or their recordings. We’ve always been internationalist in our mindset, something made clear in songs like Waving Flags, an anthem to pan-European idealism. We always wanted to be an internationalist band but maybe having a specific nation state in our name wasn’t the cleverest way to demonstrate that. We very much hope the band’s audience won’t be affronted by this adjustment to the name. We’d like to make it clear that removing the word ‘British’ does NOT indicate any aversion to the British Isles whatsoever. We all feel immensely fortunate to have grown up in these islands. Several or our songs are filled with love and awe for this place. We do love these lands. We all still live within the British Isles, but we are now just Sea Power. We feel the name change comes in part from the band’s audience—who at a good show will shout out, ‘Sea Power! Sea Power!’ Maybe this name change has been there for years, shouted in our ears. It’s just taken us this long to realize—to hear what was there in front of us…”</p>

<p> Sea Power feature Jan Scott Wilkinson (vocals/guitars), Neil Hamilton Wilkinson (vocals/guitars), Martin Noble (guitars), Matthew Wood (drums), Abi Fry (viola), and Phil Sumner (keyboards/cornet). </p>

<p> Of “Two Fingers” Yan had this to say in a press release: “The song is part inspired by our late dad. He was always giving a two-fingered salute to people on the telly—a kind of old-fashioned drinking term, toasting people or events: ‘I’ll drink two fingers to that,’ to some news item or to memories of a childhood friend. In the song it’s a toast to everyone, remembering those in our lives and those sadly no longer here and to making the world a better place. The song is &#8216;F*** me, f*** you, f*** everything.&#8217; But it’s also &#8216;Love me, love you, love everything&#8217;—exultation in the darkness. If you say ‘f*** you’ in the right way, it really can be cathartic, a new start.”</p>

<p> Yan adds: “It’s maybe interesting that the song mentions nightmare monsters from the world of HP Lovecraft. This song has been around a little while, partly because of the big interruption of Covid. Between the song being written and the album being finished, the TV series <i>Lovecraft Country</i> was broadcast—which took the supernatural Lovecraft and ran it alongside 1950s America and Lovecraft’s racism. He was a terrible racist, a white supremacist, which is why his world is there in the song, like anti-matter—something full of horror and mankind at its worst. But, alongside the negative forces in the song, there’s also a strong hopeful intent, a desire to start anew. Beyond that, the track has influences that are just inspiring—David Lynch, Cold War Steve, the Sex Pistols, Joe Meek’s Telstar, the beauty of isolated landscapes.”</p>

<p> Sea Power’s last album (released as British Sea Power of course) was 2017’s <i>Let the Dancers Inherit the Party</i>.</p>

<iframe width="100%" height="166" scrolling="no" frameborder="no" allow="autoplay" src="https://w.soundcloud.com/player/?url=https%3A//api.soundcloud.com/tracks/1092265987&amp;color=%23ff5500&amp;auto_play=false&amp;hide_related=false&amp;show_comments=true&amp;show_user=true&amp;show_reposts=false&amp;show_teaser=true"></iframe><div style="font-size: 10px; color: #cccccc;line-break: anywhere;word-break: normal;overflow: hidden;white-space: nowrap;text-overflow: ellipsis; font-family: Interstate,Lucida Grande,Lucida Sans Unicode,Lucida Sans,Garuda,Verdana,Tahoma,sans-serif;font-weight: 100;"><a href="https://soundcloud.com/seapowerband" title="Sea Power" target="_blank" style="color: #cccccc; text-decoration: none;">Sea Power</a> · <a href="https://soundcloud.com/seapowerband/two-fingers-radio-edit" title="Two Fingers" target="_blank" style="color: #cccccc; text-decoration: none;">Two Fingers</a></div>

<p>  </p>

<p> <b>3. Nation of Language: “This Fractured Mind”</b> </p>

<p> Last week Brooklyn-based synth-pop trio <a href="https://www.undertheradarmag.com/artists/nation_of_language" title="">Nation of Language</a> shared a James Thomson-directed video for their new single <a href="https://www.undertheradarmag.com/news/nation_of_language_share_video_for_new_single_this_fractured_mind" title="">“This Fractured Mind.”</a> It is the latest release from their forthcoming sophomore album <a href="https://www.undertheradarmag.com/news/nation_of_language_announce_new_album_and_tour_share_new_song_across_that_f" title=""><i>A Way Forward</i></a>, which is due out on November 5.</p>

<p> Songwriter/vocalist Ian Devaney speaks regarding the new song in a press release, stating: “After I dropped out of college, I spent a number of years delivering pizzas and waiting tables while I lived at home and tried to get a music career going. One ends up spending a lot of time contending with unrealized dreams and feeling jealousy towards those who have moved on. There’s an inferiority complex that can set in, which if unchecked, can lead down a pretty bitter and self-destructive road. This is a song for driving down that road, as indecision and longing and regret cycle together into mania, until finally, at the end, quiet acceptance and peace wash over.” </p>

<p> He adds: “As for the recording itself…for those later movements, we messed around with tape machines, running things at different speeds and sometimes backwards, talking about William Basinksi’s ‘Disintegration Loops’ and trying to see how we could achieve a similarly somber, ethereal ambiance, but in a comparatively very small space. This one in particular serves as a good example of how, on the album as a whole, we wanted to find a balance between steady motorik endlessness and more spacious ambient moments.”</p>

<p> Nation of Language consists of Ian Devaney (vocals, guitar, and percussion), Aidan Noell (synth and vocals), and Michael Sue-Poi (bass). Upon the announcement of <i>A Way Forward </i>in June, the band shared the single <a href="https://www.undertheradarmag.com/news/nation_of_language_announce_new_album_and_tour_share_new_song_across_that_f" title="">“Across That Fine Line,”</a> which was one of our <a href="https://www.undertheradarmag.com/news/12_best_songs_of_the_week_japanese_breakfast_chvrches_and_robert_smith_wolf" title="">Songs of the Week</a>. The following month, they released the song <a href="https://www.undertheradarmag.com/news/nation_of_language_share_lyric_video_for_new_song_wounds_of_love" title="">“Wounds of Love”</a> from the album (another one of our <a href="https://www.undertheradarmag.com/news/11_best_songs_of_the_week_courtney_barnett_the_goon_sax_strand_of_oaks_damo" title="">Songs of the Week</a>).</p>

<p> <i>A Way Forward </i>is the follow-up to the band’s 2020 debut album, <a href="http://www.undertheradarmag.com/reviews/nation_of_language_introduction_presence" title=""><i>Introduction, Presence</i></a>. <i>By Joey Arnone</i></p>

<p> </p><iframe width="560" height="315" src="https://www.youtube.com/embed/QikHjoLtfcw" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>4. Big Thief: “Little Things”</b> </p>

<p> This week <a href="http://www.undertheradarmag.com/artists/big_thief/" title="">Big Thief</a> shared two new songs, <a href="https://www.undertheradarmag.com/news/big_thief_share_two_new_songs_little_things_and_sparrow" title="">“Little Things”</a> and <a href="https://www.undertheradarmag.com/news/big_thief_share_two_new_songs_little_things_and_sparrow" title="">“Sparrow.”</a> They are the first newly recorded singles since their 2019 album <i><a href="http://www.undertheradarmag.com/news/big_thief_announce_second_new_album_of_2019_share_new_song_not/" title="">Two Hands</a></i>. “Little Things” taps into the more propulsive rock side of the band, which is always welcome, and gets a place on the main Songs of the Week list. The folksier “Sparrow” can be found further below in the list of songs that also came out this week.</p>

<p> Big Thief’s drummer James Krivchenia produced both songs. “Little Things” was recorded with Shawn Everrett at Five Star Studios in Topanga, CA in October 2020, whereas “Sparrow” was recorded with Sam Evian at Flying Cloud Recordings in the Catskills in July/August 2020. </p>

<p> A press release says “Little Things” is “a story built upon a very literal sense of uncertainty.” Krivchenia elaborates: “It’s in this sort of evolving free time signature where the beat is always changing, so Max [Oleartchik] and I were just flowing with it and guessing where the downbeats were—which gives the groove a really cool light feeling.”<br />
  <br />
 The version of “Sparrow” released is the band’s first take of the song. “We all just scattered about the room without headphones, focused and in the music—you could feel that something special was happening,” explains Krivchenia. “It was a funny instrumentation that had a really cool natural arrangement chemistry—Max on piano, Buck [Meek] providing this dark ambience, me on floor tom and snare and Adrianne in the middle of it with the acoustic and singing.” </p>

<p> Big Thief released two new albums in 2019, <i><a href="http://www.undertheradarmag.com/news/big_thief_announce_new_album_and_tour_share_new_song_ufof/" title="">U.F.O.F.</a> </i>and <i><a href="http://www.undertheradarmag.com/news/big_thief_announce_second_new_album_of_2019_share_new_song_not/" title="">Two Hands</a></i>. <i>Two Hands</i> was released in October 2019 via 4AD and was the “sister album” to <i>U.F.O.F.</i>, which was released in May 2019, also via 4AD. In May 2021 they released a new live EP, <i><a href="https://www.undertheradarmag.com/news/big_thief_announce_fall_tour_dates_release_new_live_ep_and_share_live_video" title="">Big Thief – Live at the Bunker Studios</a></i>, and shared a live video from the EP of the band performing <a href="https://www.undertheradarmag.com/news/big_thief_announce_fall_tour_dates_release_new_live_ep_and_share_live_video" title="">“Shoulders.”</a> </p>

<p> Big Thief consists of singer/songwriter/guitarist <a href="http://www.undertheradarmag.com/artists/adrianne_lenker" title="">Adrianne Lenker</a>, guitarist <a href="https://www.undertheradarmag.com/artists/buck_meek" title="">Buck Meek</a>, bassist Max Oleartchik, and drummer James Krivchenia. </p>

<p> Read our <a href="http://www.undertheradarmag.com/interviews/big_thief/" title="">2016 Pleased to Meet You interview with Big Thief</a>.</p>

<p> Read our <a href="http://www.undertheradarmag.com/interviews/big_thief_on_capacity/" title="">2017 interview with Big Thief on <i>Capacity</i></a>.</p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/qF0dXT-v-vY" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>5. Trace Mountains: “America”</b> </p>

<p> On Thursday <a href="https://www.undertheradarmag.com/artists/trace_mountains" title="">Trace Mountains</a> (the project of New York’s Dave Benton) announced a new album, <i><a href="https://www.undertheradarmag.com/news/trace_mountains_announces_new_album_shares_video_for_new_song_america" title="">House of Confusion</a></i>, and shared its first single, <a href="https://www.undertheradarmag.com/news/trace_mountains_announces_new_album_shares_video_for_new_song_america" title="">“America,”</a> via a video for it.<i> House of Confusion </i>is due out October 22 via Lame-O. Check out the album’s tracklist and cover art <a href="https://www.undertheradarmag.com/news/trace_mountains_announces_new_album_shares_video_for_new_song_america" title="">here</a>.</p>

<p> “‘America’ is a road song written from a place of disillusionment and desperation,” says Benton in a press release. “My guitarist Jim Hill created this video inspired in equal parts by <i>Easy Rider</i>, <i>Wayne’s World</i>, and <i>The Lord of the Rings</i> to mirror the themes of the song in jest. Writing and arranging this song was a real journey for us, with lots of rewrites and changes. I almost cut the song from the album at one point because it was torturing me so much! I wanted it to be real but also lighthearted and upbeat. I think Jim captured that energy perfectly in his visual interpretation of the song.”</p>

<p> <i>House of Confusion </i>is the third Trace Mountains album and the follow-up to 2020’s <i>Lost in the Country</i>. It was recorded in the winter of 2021 in various locations—“a studio in the foothills of the Shawangunk Ridge in New York, a home along the Rondout Creek of the Hudson Valley, a Brooklyn apartment, and a small shared music workspace in Denver, Colorado” is how a press release describes them. </p>

<p> Benton was aided in the recordings by his regular backing band—Jim Hill (guitar, keys), Greg Rutkin (drums), and Susannah Cutler (voice, mellotron). Also joining in were Bernard Casserly (bass), J.R. Bohannon (pedal steel, guitar), David Grimaldi (guitar - tracks four and five), and Ryan Jewell (drums, marimba - track four).</p>

<p> Benton lost his job due to the pandemic and so found himself with the time to quickly follow-up <i>Lost in the Country</i>. “I was used to waking up early for my warehouse job, so when I got laid off, I just kept up that schedule and implemented another daily regimen focused on improving my guitar playing and writing songs,” he explains in the press release. </p>

<p> “I was on the road in my mind,” he adds, “thinking back on my life as a musician—my successes, my failures—and I was reflecting on the ever-ongoing process of moving on that my life has been made up of.”</p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/WzRufA4b3dg" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>6. Macie Stewart: “Garter Snake” (Feat. Sen Morimoto)</b></p>

<p> Chicago-based singer/songwriter and multi-instrumentalist <a href="https://www.undertheradarmag.com/artists/macie_stewart/" title="">Macie Stewart</a> has made a career as a consummate collaborator and a mainstay of the Chicago music scene. They’ve immersed themself in the city’s avant-garde jazz scene, lent their talents as a string arranger to Whitney, SZA, and V.V. Lightbody, and crafted dense experimental rock as one-half of the excellent duo <a href="https://www.undertheradarmag.com/artists/ohmme/" title="">Ohmme</a>.</p>

<p> This fall though we’re are being introduced to Stewart as a solo artist with the release of her upcoming debut album <i>Mouth Full of Glass</i>, due out September 24th via Orindal Records. She’s already shared her sweeping lead single “Finally,” and on Wednesday she shared the follow-up, <a href="https://www.undertheradarmag.com/news/premiere_macie_stewart_of_ohmme_debuts_new_single_garter_snake" title="">“Garter Snake,”</a> premiering with <i>Under the Radar</i>.</p>

<p> “Garter Snake” is similarly intimate and lovingly arranged as its predecessor, this time finding Stewart reflecting on impenetrable solitude. She envisions herself as a garden snake, unnoticed and “new, alone, and awake.” Stewart’s vocals lilt above gentle fingerpicked guitar, initially solitary, only for keyboards and strings to fall into the track like beams of sunlight, breaking through its isolated facade. Later, Sen Morimoto’s saxophone joins the gorgeous swirl of instrumentation, adding a winding highlight to the track. The result is a work of earthen beauty, filtering Stewart’s loneliness and isolation into naturalistic chamber pop delight. </p>

<p> Stewart says of the track, “This song came out of staring at the wall for an unprecedented amount of time. Garter snakes kept coming up in my life—I was going on a lot of outdoor hikes, and they kept appearing in images I was encountering. There are many negative connotations with snakes, but Garter Snakes are harmless at best. I was fascinated by their growth and shedding process and wanted that for myself. Sen Morimoto’s saxophone really tied together the entire vision—it feels like an aural representation of the snake motif that appears throughout the song.”</p>

<p> She continues, saying of the video: “<a href="https://www.emilyesperanza.com/" title="">Emily Esperanza</a> had such a beautiful vision of tableaus for the video, and it was a pleasure to work with them. I hadn’t traveled anywhere in over a year—so going to Marfa to stay and work with them was so creatively fulfilling. I am really grateful to them and the beautiful crew I encountered down there for making it all happen.” </p>

<p> You can also read our review of Ohmme’s 2020 album <i>Fantasize Your Ghost</i> <a href="https://www.undertheradarmag.com/reviews/ohmme_fantasize_your_ghost" title="">here</a>. <i>By Caleb Campbell</i></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/chhYUEENywI" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>7. Courtney Barnett: “Before You Gotta Go”</b> </p>

<p> <a href="http://www.undertheradarmag.com/artists/courtney_barnett/" title="">Courtney Barnett</a> is releasing a new album, <i><a href="https://www.undertheradarmag.com/news/courtney_barnett_announces_new_album_shares_video_for_new_song_rae_street" title="">Things Take Time, Take Time</a></i>, on November 12 via Mom + Pop Music/Marathon Artists. On Wednesday she shared its second single, the relaxed <a href="https://www.undertheradarmag.com/news/courtney_barnett_shares_new_song_before_you_gotta_go" title="">“Before You Gotta Go.”</a> </p>

<p> “Sometimes I try to say everything in one song, or put my whole belief system into a vox pop, but you just can&#8217;t do that — it&#8217;s impossible,” Barnett says of the song in a press release. </p>

<p> Previously Barnett shared the album’s first single, <a href="https://www.undertheradarmag.com/news/courtney_barnett_announces_new_album_shares_video_for_new_song_rae_street" title="">“Rae Street,”</a> via an amusing video where Barnett plays multiple characters. “Rae Street” was #1 on our <a href="https://www.undertheradarmag.com/news/11_best_songs_of_the_week_courtney_barnett_the_goon_sax_strand_of_oaks_damo" title="">Songs of the Week</a> list.<i> </i></p>

<p> Barnett’s last album, <a href="http://www.undertheradarmag.com/news/courtney_barnett_announces_new_album_shares_video_for_new_song_nameless_fac/" title=""><i>Tell Me How You Really Feel</i></a>, was released back in May 2018 via Mom + Pop/Marathon Artists/Milk! Records. It was our <a href="http://www.undertheradarmag.com/news/album_of_the_week_courtney_barnett_tell_me/" title="">Album of the Week</a> and one our <a href="http://www.undertheradarmag.com/news/under_the_radars_top_100_albums_of_2018/" title="">Top 100 Albums of 2018</a>. </p>

<p> <i>Things Take Time, Take Time </i>was written over a two-year period and was recorded in Sydney, Northern NSW, and Melbourne in late 2020/early 2021 with the aid of Warpaint drummer Stella Mozgawa (who is also Australian and also worked with Kurt Vile, John Grant, Cate Le Bon, The xx, and others). W.A.M. Bleakley directed the “Rae Street” video. </p>

<p> A previous press release hyped up the album this way: “<i>Things Take Time, Take Time<b> </b></i>is yet another assured leap forward for Barnett; a breakthrough really, but not in the ways you might expect. This is Barnett at her most creative and adventurous—an exquisite look at Courtney’s private world, and consequently her most beautiful and intimate record to date, with songs dealing unabashedly with love, renewal, healing and self-discovery.”</p>

<p> Read <a href="http://www.undertheradarmag.com/interviews/courtney_barnett_-_the_under_the_radar_cover_story/" title="">our 2018 cover story on Courtney Barnett here</a>.</p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/5cD1LP80JvQ" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>8. Sufjan Stevens and Angelo De Augustine: “Back to Oz”</b></p>

<p> <a href="http://www.undertheradarmag.com/artists/sufjan_stevens" title="">Sufjan Stevens</a> and <a href="https://www.undertheradarmag.com/artists/angelo_de_augustine" title="">Angelo De Augustine</a> are releasing a new collaborative album together, <i><a href="https://www.undertheradarmag.com/news/sufjan_stevens_and_angelo_de_augustine_announce_new_collaborative_album_sha" title="">A Beginner’s Mind</a></i>, on September 24 via Asthmatic Kitty and on Tuesday they shared two new songs from it, <a href="https://www.undertheradarmag.com/news/sufjan_stevens_and_angelo_de_augustine_share_two_new_songs_back_to_oz_and_f" title="">“Back to Oz”</a> (shared via a video) and <a href="https://www.undertheradarmag.com/news/sufjan_stevens_and_angelo_de_augustine_share_two_new_songs_back_to_oz_and_f" title="">“Fictional California.”</a> The album is inspired by different films, with “Back to Oz” taking inspiration from 1985’s <i>Return to Oz </i>and “Fictional California” being inspired by 2004’s direct-to-video cheerleading comedy sequel <i>Bring It On Again</i>. Alex Horan directed the “Back to Oz” video, which was animated by Clara Murray. We liked “Back to Oz” best and it makes the main Songs of the Week list, whereas “Fictional California” is an honorable mention below.</p>

<p> Stevens is based in New York, De Augustine lives in Thousand Oaks, CA. Both artists are already on Asthmatic Kitty and the album came together during a month long songwriting retreat between the two of them in a friend’s Upstate New York cabin. At the end of each day they’d watch a movie to unwind and the movies started to inform their songwriting, so much so that the songs on <i>A Beginner’s Mind </i>are each loosely based on a film.</p>

<p> De Augustine had this to say about “Back to Oz” in a press release: “This was a song that I had written mostly at home in California. We finished its lyrics after watching <i>Return to Oz</i>. The words reference an erosion of a central character’s internal reality. A loss of innocence is the impetus for a journey to find inner truth. In the film, Dorothy returns to the world of Oz to find its landscape in ruins and its citizens frozen in stone. Only she can find the ruby slippers and return peace to Oz. Only we can save ourselves, but we first have to remember who we truly are.” </p>

<p> Stevens adds: “Angelo is mostly known for his intimate home recordings; his music is quiet and confessional. So for ‘Back to Oz’ we decided to go for something flashier. The song has a fun guitar groove, so we gave it some bass and drums, and Angelo even recorded his first electric guitar solo. It’s a sad song—being mostly about disillusionment—but it has a great party vibe too.” </p>

<p> Horan had this to say about directing the “Back to Oz” video: “We love the dreamlike quality of ‘Back to Oz’ and how the chorus transports the listener to another world. We wanted to evoke those same feelings through the visuals.”</p>

<p> Animated Murray adds: “I love to make anything and everything come alive—the clouds, a fork—everything has a soul and can become a living, breathing thing. So the idea of creating a whole world engrossed me.” </p>

<p> When the album was announced, Stevens and De Augustine shared two songs from it, <a href="https://www.undertheradarmag.com/news/sufjan_stevens_and_angelo_de_augustine_announce_new_collaborative_album_sha" title="">“Reach Out”</a> and <a href="https://www.undertheradarmag.com/news/sufjan_stevens_and_angelo_de_augustine_announce_new_collaborative_album_sha" title="">“Olympus.”</a> The former was shared via a VHS-shot video featuring their dogs Joku and Charlie and was one of our <a href="https://www.undertheradarmag.com/news/11_best_songs_of_the_week_courtney_barnett_the_goon_sax_strand_of_oaks_damo" title="">Songs of the Week</a>. </p>

<p> Earlier this year Stevens released the five-volume album <a href="http://www.undertheradarmag.com/news/sufjan_stevens_announces_new_five_volume_album_shares_new_song_meditation_v" title=""><i>Convocations</i></a>. De Augustine’s most recent album was 2019’s <i><a href="https://www.undertheradarmag.com/reviews/angelo_de_augustine_tomb" title="">Tomb</a></i>.</p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/00f2kSnIxfw" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>9. Indigo De Souza: “Real Pain”</b></p>

<p> North Carolina singer/songwriter <a href="https://www.undertheradarmag.com/artists/indigo_de_souza" title="">Indigo De Souza</a> is releasing a new album, <i><a href="https://www.undertheradarmag.com/news/indigo_de_souza_announces_new_album_shares_video_for_new_song_kill_me" title="">Any Shape You Take</a></i>, on August 27 via Saddle Creek. On Wednesday she shared its third single, <a href="https://www.undertheradarmag.com/news/indigo_de_souza_shares_new_song_real_pain" title="">“Real Pain,”</a> which really takes life midway through when things get a bit noisier.   </p>

<p> De Souza had this to say in a press release: “‘Real Pain’ is about facing grief and loss and having compassion for yourself in that space. It&#8217;s about learning to be unafraid of experiencing a full spectrum of emotion, and welcoming the way it teaches you and changes you. For one of the sections in the song, I put out an invitation for people to anonymously send me voice memos of ‘screams, yells, and anything else.’ I layered the voices on top of one another to embody a kind of collective experience. I felt an incredible catharsis hearing their voices stacked with mine. While we live such separate lives, we are connected in the way that we all navigate immense amounts of pain and love and fear in our bodies every day. It can be hard to be a person! It&#8217;s okay to acknowledge that sometimes. It&#8217;s okay to feel things fully and to allow others space to do the same.” </p>

<p> Previously De Souza shared the album’s first single, <a href="https://www.undertheradarmag.com/news/indigo_de_souza_announces_new_album_shares_video_for_new_song_kill_me" title="">“Kill Me,”</a> via a video for it. “Kill Me” was one of our <a href="https://www.undertheradarmag.com/news/12_best_songs_of_the_week_tachys_ora_the_molecule_wet_leg_indigo_de_souza_a" title="">Songs of the Week</a>. Then she shared its second single, the upbeat ode to community and free expression, <a href="https://www.undertheradarmag.com/news/indigo_de_souza_shares_video_for_new_song_hold_u" title="">“Hold U,”</a> via a video for it. “Hold U” was also one of our <a href="https://www.undertheradarmag.com/news/12_best_songs_of_the_week_the_war_on_drugs_penelope_isles_indigo_de_souza_p" title="">Songs of the Week</a>. </p>

<p> <i>Any Shape You Take </i>is the follow-up to her 2018 debut, <i>I Love My Mom</i>, which was self-released and recently reissued by Saddle Creek. De Souza co-produced the new album with Brad Cook (Bon Iver, Waxahatchee).</p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/VUe4zYAZsMg" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>10. Sam Evian: “Knock Knock”</b></p>

<p> On Monday <a href="https://www.undertheradarmag.com/artists/sam_evian" title="">Sam Evian</a> announced a new album, <i><a href="https://www.undertheradarmag.com/news/sam_evian_announces_new_album_and_tour_shares_video_for_new_song_knock_knoc" title="">Time to Melt</a></i>, and shared its first single, <a href="https://www.undertheradarmag.com/news/sam_evian_announces_new_album_and_tour_shares_video_for_new_song_knock_knoc" title="">“Knock Knock,”</a> via a video for it. He also announced some new tour dates. <i>Time to Melt </i>is due out October 29 via Fat Possum. Check out the album’s tracklist and cover art, as well as the tour dates, <a href="https://www.undertheradarmag.com/news/sam_evian_announces_new_album_and_tour_shares_video_for_new_song_knock_knoc" title="">here</a>. </p>

<p> Evian recorded the album in his own studio, Flying Cloud Recordings, in a Catskills town in Upstate New York, where he lives with his romantic partner, fellow musician <a href="https://www.undertheradarmag.com/artists/hannah_cohen" title="">Hannah Cohen</a> after decamping from New York City. The album was recorded during the pandemic and it features Cohen, as well as remote contributions from Spencer Tweedy, Chris Bear, and Jon Natchez (The War on Drugs). </p>

<p> “&#8216;Knock Knock&#8217; is a song of commiseration,” says Evian in a press release, of the new single. “It&#8217;s a conversation with my sibling, and really anyone else with a conscience. We talk a lot about the small town in Eastern North Carolina where we grew up, and why we left. Growing up we saw a lot of racism, violence, poverty, disparity, ignorance…all of it not so hidden under a veil of southern hospitality and dogmatic beliefs. A year later after George Floyd’s murder, I hope we can keep the conversation going. The veil is lifted for all to see. Knock knock—who&#8217;s there? A broken America.” </p>

<p> Evian’s last album was 2018’s <i><a href="https://www.undertheradarmag.com/reviews/sam_evian_you_forever" title="">You, Forever</a></i>.</p>

<p> On tour Evian will be joined by Brian Betancourt (bass), Michael Coleman (keys), Sean Mullins (drums), and Liam Kazar (guitar, synths).</p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/pa6s2taK8l4" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>11. Strand of Oaks: “Jimi &amp; Stan”</b></p>

<p> Last week <a href="https://www.undertheradarmag.com/news/strand_of_oaks_announces_new_album_shares_new_song_galacticana" title="">Strand of Oaks</a> (the project of Timothy Showalter) shared a new song titled <a href="https://www.undertheradarmag.com/news/strand_of_oaks_shares_new_song_jimi_stan" title="">“Jimi &amp; Stan.”</a> It is the latest offering from his forthcoming album <a href="https://www.undertheradarmag.com/news/strand_of_oaks_announces_new_album_shares_new_song_galacticana" title=""><i>In Heaven</i></a>, due out October 1 on Galacticana Records via Thirty Tigers. </p>

<p> “Jimi &amp; Stan,” like other songs on <i>In Heaven</i>, deals with grief and the loss of a loved one. Showalter explains in a press release the meaning behind the song: “My sweetest buddy/cat Stan sadly passed away. And the only way I could describe my love for him was imagining Stan and Jimi Hendrix hanging out in heaven together smiling and going to shows and having the best time.” </p>

<p> Upon the announcement of <i>In Heaven</i>, Showalter shared the song <a href="https://www.undertheradarmag.com/news/strand_of_oaks_announces_new_album_shares_new_song_galacticana" title="">“Galacticana,”</a> which was one of our <a href="https://www.undertheradarmag.com/news/11_best_songs_of_the_week_courtney_barnett_the_goon_sax_strand_of_oaks_damo" title="">Songs of the Week</a>. His previous album, <a href="https://www.undertheradarmag.com/news/strand_of_oaks_announces_new_album_backed_by_my_morning_jacket_shares_new_s/" title=""><i>Eraserland</i></a>, came out in 2019 and was #5 on our <a href="https://www.undertheradarmag.com/lists/under_the_radars_top_100_albums_of_2019" title="">Top 100 Albums of 2019</a> list. <i>By Joey Arnone</i></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/n9AWNqT1sfw" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>12. Hayden Thorpe: “Parallel Kingdom”</b></p>

<p> Last week <a href="https://www.undertheradarmag.com/artists/hayden_thorpe" title="">Hayden Thorpe</a>, former singer for British art-rockers <a href="https://www.undertheradarmag.com/artists/wild_beasts" title="">Wild Beasts</a>, shared a video for a new song titled <a href="https://www.undertheradarmag.com/news/hayden_thorpe_shares_video_for_new_song_parallel_kingdom" title="">“Parallel Kingdom.”</a> It is the second single from his forthcoming album <a href="https://www.undertheradarmag.com/news/hayden_thorpe_announces_new_album_shares_video_for_new_song_the_universe_is" title=""><i>Moondust For My Diamond</i></a>, due out on October 15 via Domino. The Tom Haines-directed video was shot at Swinside Stone Castle in Thorpe’s homeland The Lake District. </p>

<p> Regarding the picturesque setting for the video, Thorpe states in a press release: “There are ancient stories to be told here, aeons play out in a single glance. Using Swinside Stone Circle as a location gave everything a certain sanctity.” He adds: “So much of our existence is an inconceivable wonder yet we’re so distracted that we rarely register the immenseness of the moment. Right there, beside us all along, is the wonder of everything.”</p>

<p> “Parallel Kingdom” is the result of Thorpe’s collaboration with producer Richard Formby. The two were working on a bassline that Thorpe had written years earlier, which Formby subsequently ran through a self-built monolithic modular synthesizer. <i>Moondust For My Diamond</i> features production by Formby along with Nathan Jenkins (Bullion). </p>

<p> Upon the announcement of <i>Moondust For My Diamond</i> last month, Thorpe shared its lead single <a href="https://www.undertheradarmag.com/news/hayden_thorpe_announces_new_album_shares_video_for_new_song_the_universe_is" title="">“The Universe Is Always Right,”</a> which was one of our <a href="https://www.undertheradarmag.com/news/11_best_songs_of_the_week_courtney_barnett_the_goon_sax_strand_of_oaks_damo" title="">Songs of the Week</a>. His debut album, <a href="https://www.undertheradarmag.com/news/hayden_thorpe_formerly_of_wild_beasts_announces_solo_album_shares_new_song_/" title=""><i>Diviner</i></a>, came out in 2019 via Domino.</p>

<p> Read <a href="http://www.undertheradarmag.com/interviews/hayden_thorpe_on_diviner/" title="">our interview with Hayden Thorpe on </a><a href="http://www.undertheradarmag.com/interviews/hayden_thorpe_on_diviner/" title=""><i>Diviner</i></a>.</p>

<p> Read <a href="http://www.undertheradarmag.com/interviews/self-portrait_hayden_thorpe/" title="">our Self-Portrait feature with Hayden Thorpe</a>. <i>By Joey Arnone</i></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/cxTaWxVHc8s" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Honorable Mentions:</b></p>

<p> These songs almost made the Top 12. Lala Lala was almost #13 on our main list before we decided to limit it to a Top 12. We quite liked the Say Sue Me song too.</p>

<p> <b>Cherry Glazerr: “Soft Drink”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/xuuErrlTIqo" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Duran Duran: “MORE JOY!” (Feat. CHAI)</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/FCHQu8sZwGI" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Danny Elfman &amp; Trent Reznor: “True”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/V1adLb9c6U4" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Injury Reserve: “Knees”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/AvYU1mIMiuY" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>The Joy Formidable: “Interval”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/AH1ewx6d8j4" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Lala Lala: “Color of the Pool”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/TQ-9w4oZog4" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Say Sue Me: “So Tender”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/ub80ksenGH8" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Sufjan Stevens and Angelo De Augustine: “Fictional California”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/n-LNasIR2cM" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Other notable new tracks in the last two weeks include:</b></p>

<p> <b>Big Red Machine: “Mimi” (Feat. Ilsey)</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/FfhIamjLPMU" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Big Thief: “Sparrow”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/wBc-yGE7IkU" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>black midi: “Cruising”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/YJleqBqXlpA" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Phoebe Bridgers: “Nothing Else Matters” (Metallica Cover)</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/0TR1Uk5oV5c" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Cash and Skye: “No More Candy” and “Sweeping Wet Floors”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/A9RYMqOQGB0" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/Rs-57XIDLfw" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>The Charlatans: “Tellin’ Stories (The Go! Team Remix)”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/ZRa6eOUkDqs" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>CHVRCHES: “Good Girls John Carpenter Remix)” and John Carpenter: “Turning the Bones (CHVRCHES Remix)”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/ypUwRjH9sAU" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/YU3QgHk6o3U" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>The Cribs: “Swinging At Shadows”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/kmrpku2dMCs" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Damon &amp; Noami: “The Aftertime”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/QKd6XeIQDK0" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Deafheaven: “In Blur”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/fXTBQQU191Y" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>FINNEAS: “A Concert Six Months From Now”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/TB6lk0igf_k" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>GLOK: “Closer”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/qS6lyIWkkW0" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Hand Habits: “Aquamarine”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/JkfuBg2DhlM" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>The Killers: “Runaway Horses” (Feat. Phoebe Bridgers)</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/T6nU2aoqNsw" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Morly: “Eliogy”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/aCgrs9n2CJo" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Porridge Radio: “You Are a Runner and I Am My Father’s Son” (Wolf Parade Cover)</b></p>

<iframe style="border: 0; width: 100%; height: 120px;" src="https://bandcamp.com/EmbeddedPlayer/album=2341437852/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/track=3874171642/transparent=true/" seamless=""><a href="https://porridgeradio.bandcamp.com/album/you-are-a-runner-and-i-am-my-fathers-son">You Are a Runner and I Am My Father&#39;s Son by Porridge Radio</a></iframe><p> </p>

<p> <b>Public Service Broadcasting: “Blue Heaven” (Feat. Andreya Casablanca)</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/XhX3QrVtl_M" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Purity Ring: “soshy”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/zqBGLAG8OmY" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Soft Cell: “Heart Like Chernobyl”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/GnheY81x3dM" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Tasha: “Lake Superior”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/mGDrqbyCxwQ" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Alexis Taylor: “House of the Truth”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/0DlIAC1EWMM" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Turnstile: “Fly Again”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/-xHt98f5JxI" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Unknown Mortal Orchestra: “That Life”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/UJXccBGs_IY" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Sharon Van Etten and Angel Olsen: “Like I Used To (Acoustic Version)”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/PsugnY-f904" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>Washed Out: “Sidney’s Lullaby” and “Miles’ Lullaby”</b></p>

<iframe style="border: 0; width: 100%; height: 120px;" src="https://bandcamp.com/EmbeddedPlayer/album=3391609117/size=large/bgcol=ffffff/linkcol=0687f5/tracklist=false/artwork=small/transparent=true/" seamless=""><a href="https://washedout.bandcamp.com/album/sidneys-lullaby">Sidney&#39;s Lullaby by Washed Out</a></iframe><p> </p>

<p> <b>The Weeknd: “Take My Breath”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/rhTl_OyehF8" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>We Were Promised Jetpacks: “Not Me Anymore”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/ogqTqq_Az18" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <b>The World is a Beautiful Place &amp; I am No Longer Afraid to Die: “Invading the World of the Guilty as a Spirit of Vengeance”</b></p>

<iframe width="560" height="315" src="https://www.youtube.com/embed/P_BmtqMoqOQ" title="YouTube video player" frameborder="0" allow="accelerometer; autoplay; clipboard-write; encrypted-media; gyroscope; picture-in-picture" allowfullscreen=""></iframe><p> </p>

<p> <a href="https://www.patreon.com/under_the_radar" target="_blank">Support <i>Under the Radar </i>on Patreon.</a></p>

<br /><br />
<script>
/* In-Read undertheradarmag */
(function() {
	var opts = {
		artist: "",
		song: "",
                detect_artist: true,
		adunit_id: 100001447,
		div_id: "cf_async_" + Math.floor((Math.random() * 999999999))
	};
	document.write('<div id="'+opts.div_id+'"></div>');var c=function(){cf.showAsyncAd(opts)};if(typeof window.cf !== 'undefined')c();else{cf_async=!0;var r=document.createElement("script"),s=document.getElementsByTagName("script")[0];r.async=!0;r.src="//srv.clickfuse.com/showads/showad.js";r.readyState?r.onreadystatechange=function(){if("loaded"==r.readyState||"complete"==r.readyState)r.onreadystatechange=null,c()}:r.onload=c;s.parentNode.insertBefore(r,s)};
})();
</script>

<div id="ac5b40b8-b46a-4683-8e5f-ae810fc8e1b6" class="_inv_marker"></div>

<div class="ad interior">
<!-- /5381216/UTR_FullSite_Square_300x250 -->
<div id='div-gpt-ad-1549376717402-0' style='height:250px; width:300px;'>
<script>
googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376717402-0');});
</script>
</div>
</div>



<div id="taboola-below-article-thumbnails"></div>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({
    mode: 'alternating-thumbnails-a',
    container: 'taboola-below-article-thumbnails',
    placement: 'Below Article Thumbnails',
    target_type: 'mix'
  });
</script>

<div id="comments">
	<h3>Comments</h3>
	<div id="comments-form" class="clearfix">
		<h4>Submit your comment</h4>
<form id="comment_form" method="post" action="https://www.undertheradarmag.com/news/12_best_songs_of_the_last_two_weeks_magdalena_bay_sea_power_nation_of_langu"  >
<div class='hiddenFields'>
<input type="hidden" name="ACT" value="1" />
<input type="hidden" name="RET" value="https://www.undertheradarmag.com/news/12_best_songs_of_the_last_two_weeks_magdalena_bay_sea_power_nation_of_langu" />
<input type="hidden" name="URI" value="news/12_best_songs_of_the_last_two_weeks_magdalena_bay_sea_power_nation_of_langu" />
<input type="hidden" name="PRV" value="" />
<input type="hidden" name="entry_id" value="48151" />
<input type="hidden" name="site_id" value="1" />
<input type="hidden" name="csrf_token" value="218d0c94bdab9aa668bbe8e58fa462bd3e835174" />
</div>

<p><input name="name" type="text" class="text" value="" />Name <span class="vamp">Required</span></p>
		<p><input name="email" type="text" class="text" value="" />Email <span class="vamp">Required, will not be published</span></p>		
		<p><input name="url" type="text" class="text" value="http://" />URL</p>
		<p><textarea name="comment"></textarea></p>
		<p>
			<input type="checkbox" name="save_info" value="yes"  /> Remember my personal information<br />
			<input type="checkbox" name="notify_me" value="yes"  /> Notify me of follow-up comments?
		</p>

		<p>Please enter the word you see in the image below:</p>
		<p id="captcha">
			<img src="/images/captchas/1628927278.9357.jpg" width="140" height="30" style="border:0;" alt=" " /><input type="text" class="text" name="captcha" value="" maxlength="20" />
		</p>

		<p><input id="submit-comment" type="submit" value="Submit" /></p></form>
	</div>

	<p id="nocomments">There are no comments for this entry yet.</p>
	
</div>

</div>


<!-- Right Rail -->
<div id="rightrail" class="rail  col s12 m3 l3">

		<div class="module">
			<h2><a href="/issues/current/"><b>Current Issue</b></a></h2>
			<a href="https://www.undertheradarmag.com/issues/46771"><img src="https://www.undertheradarmag.com/uploads/cover_images/Under_the_Radar_Issue_68_Cover_Japanese_Breakfast_HAIM_696_Protest_Issue_Issue_Page.jpg" width="204" alt="" /></a>
			<h3><a href="https://www.undertheradarmag.com/issues/46771"><strong>Issue #68</strong></a></h3>
			<p class="details">
				<span class="date">Apr 21, 2021</span>
				<a href="https://www.undertheradarmag.com/issues/46771">Issue #68 - Japanese Breakfast and HAIM (The Protest Issue)</a>
			</p>
                  </div>
	



 
	<div class="module">
		<h2><b>Most Recent</b></h2>
	<ul class="zebra">
				
			
						
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
                    	
						<li class="stripe"><a href="/news/12_best_songs_of_the_last_two_weeks_magdalena_bay_sea_power_nation_of_langu"><strong>12 Best Songs of the Last Two Weeks: Magdalena Bay, Sea Power, Nation of Language, and More</strong> (News) &mdash; Songs of the Week, British Sea Power, Sea Power, Magdalena Bay, Nation of Language, Big Thief, Trace Mountains, Macie Stewart, Courtney Barnett, Sufjan Stevens and Angelo De Augustine, Sufjan Stevens, Angelo De Augustine, Indigo De Souza, Sam Evian, Strand of Oaks, Hayden Thorpe</a></li>			
                    	
						<li  ><a href="/news/premiere_hollow_coves_debuts_new_video_for_blessings"><strong>Premiere: Hollow Coves Debuts New Video For “Blessings”</strong> (News) &mdash; Hollow Coves</a></li>			
                    	
						<li class="stripe"><a href="/news/premiere_damn_jackals_debut_new_video_for_lovely_nuthin"><strong>Premiere: Damn Jackals Debut New Video For “Lovely Nuthin”</strong> (News) &mdash; Damn Jackals</a></li>			
                    	
                    	
                    	
						<li  ><a href="/news/the_killers_stream_the_new_album_including_runaway_horses_which_features_ph"><strong>The Killers – Stream the New Album, Including “Runaway Horses” Which Features Phoebe Bridgers</strong> (News) &mdash; The Killers, Phoebe Bridgers, Brandon Flowers</a></li>			
                    	
						<li class="stripe"><a href="/interviews/director_ferdinando_cito_filomarino_on_his_new_netflix_film_beckett"><strong>Director Ferdinando Cito Filomarino on His New Netflix Film “Beckett”</strong> (Interview) &mdash; Ferdinando Cito Filomarino</a></li>
			
				</ul>
	</div>


	
<div class="ad">

<!-- /5381216/UTR_FullSite_Skyscraper_160x600 -->
<div id='div-gpt-ad-1549376881449-0' style='height:600px; width:160px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376881449-0');});</script>
</div>
<br />
</div>

	<div class="ad"><a href="//twitter.com/under_radar_mag" target="_blank" onclick="pageTracker._trackPageview('/outgoing/Twitter');"><img src="https://www.undertheradarmag.com/uploads/ads/d4eb7c808a2baa538f2f5d6ee374fe33.jpg" alt="" /></a></div>
         <br />


	
<div class="ad">
<!-- /5381216/UTR_ROS_Skyscraper_Right_bottom -->
<div id='div-gpt-ad-1549376944969-0' style='height:600px; width:160px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376944969-0');});</script>
</div>
</div>

</div><!--/right-rail-->

</div> <!--end content/row-->	




<div id="footer-ad" class="hide-on-med-and-down">
<!-- /5381216/UTR_ROS_Leaderboard-Bottom -->
<div id='div-gpt-ad-1549376996058-0' style='height:90px; width:728px;'>
<script>googletag.cmd.push(function() {googletag.display('div-gpt-ad-1549376996058-0');});</script>
</div>
</div>

<div id="footer">
	<a href="https://www.undertheradarmag.com/contact">Contact</a>
	<a href="https://www.undertheradarmag.com/site/static/staff">Staff</a>
	<a href="https://www.undertheradarmag.com/about">About Us</a>
	<span id="credit">Site by <a href="http://someoddpilot.com/">Someoddpilot</a> &amp; <a href="http://methodtree.com">Methodtree, Inc.</a></span>
	<a href="/" class="copyright">&copy; Under The Radar Magazine</a>
</div>

</div> <!--end page-->

<script type="text/javascript" src="/assets/js/materialize.min.js"></script>


<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>

</body>
</html>